RVM fails migrating gems #1424

Closed
AdrienGiboire opened this Issue Jan 5, 2013 · 6 comments

2 participants

@AdrienGiboire

I saw this closed issue: #1315

I got the same but it actually came after running rvm get stable then running rvm upgrade 1.9.3, this trying to install ruby-1.9.3-p362.

Migrating gems from 1.9.3 to ruby-1.9.3-p362
Source and Destination Ruby are the same (ruby-1.9.3-p362)
Error migrating gems.

It worked when running rvm upgrade 1.9.3-p194 1.9.3-p362 instead.

Is that normal it didn't worked the first time?

@mpapis
Ruby enVironment Manager member

1) make sure you test with head:

rvm get head

2) provide a gist (still on head):

rvm --trace upgrade 1.9.3
@AdrienGiboire

Why can't I use stable, as I did, instead of head?

The gist is not complete but I think it's already way too much: https://gist.github.com/4463852 :)

@mpapis
Ruby enVironment Manager member

you can not use stable because we fix bugs on head and then if possible merge back to stable, finally head helps to synchronize your debugging information with source code.

as for the error, can you run (and show the output):

rvm list strings
rvm list strings | GREP_OPTIONS="" \grep -E "^ruby-1.9.3|^1.9.3$"
@AdrienGiboire

So, I tried with head instead and I got same issue. The new gist: https://gist.github.com/4469079 A bit shorter, I don't think everything was relevant.

Result of rvm list strings:

ruby-1.8.7-p358
ruby-1.9.3-p194
ruby-1.9.3-p362
@mpapis
Ruby enVironment Manager member

actually I need to ask you for whole output as some parts should be calculated a lot earlier and I need to know what was done on beginning.

also could you run:

rvm list strings | GREP_OPTIONS="" \grep -E "^ruby-1.9.3|^1.9.3$"
@AdrienGiboire
○ rvm list strings | GREP_OPTIONS="" \grep -E "^ruby-1.9.3|^1.9.3$"
ruby-1.9.3-p194
ruby-1.9.3-p362

The full trace: https://gist.github.com/4470215

@mpapis mpapis closed this in 1999359 Jan 6, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment