rvm install ruby-2.0.0-0 installs incompatiable bundler #1587

Closed
mipearson opened this Issue Feb 24, 2013 · 2 comments

3 participants

@mipearson
$ rvm get head
...
$ rvm install ruby-2.0.0
...
$ rvm use ruby-2.0.0; gem list
*** LOCAL GEMS ***

bigdecimal (1.2.0)
bundler (1.2.4)
io-console (0.4.2)
json (1.7.7)
minitest (4.3.2)
psych (2.0.0)
rake (10.0.3, 0.9.6)
rdoc (4.0.0)
rubygems-bundler (1.1.0)
rvm (1.11.3.6)
test-unit (2.0.0.0)

$ cd myapp; bundle install
Bundler is not compatible with Ruby 2.0 or Rubygems 2.0.
Please upgrade to Bundler 1.3 or higher.

Fixed manually by running gem update bundler --pre

IMO either have RVM do this or do not install bundler by default.

@mpapis mpapis was assigned Feb 24, 2013
@envygeeks

👍 --pre.

@mipearson

oh also:

$ rvm version
rvm 1.18.13 (master) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

$ uname -a
Darwin MP.local 12.2.1 Darwin Kernel Version 12.2.1: Thu Oct 18 12:13:47 PDT 2012; root:xnu-2050.20.9~1/RELEASE_X86_64 x86_64
@mpapis mpapis closed this in 5eb07bd Feb 24, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment