(can not require mysql2) rvm stable recently lost the ability to build ruby 'head' #1714

rubys opened this Issue Mar 23, 2013 · 7 comments

3 participants


I initially reported this to ruby-lang, but they were right, this is an rvm issue:


On the same machine, I can check out the source from svn, run autoconf, make, make install and run the executables successfully. Minor unrelated note, builds using rvm don't report the svn branch and version number:

$ ruby -v
ruby 2.1.0dev (2013-03-22) [x86_64-linux]

When I build it myself, I see:

$ ruby -v
ruby 2.1.0dev (2013-03-23 trunk 39883) [x86_64-linux]

Can you please confirm this is the case with rvm head too, by doing:

rvm get head
rvm reload
rvm install ...

I'm seeing the same problem with rvm head:

$ rvm -v
rvm 1.18.21 (master) by Wayne E. Seguin <wayneeseguin@gmail.com>, Michal Papis <mpapis@gmail.com> [https://rvm.io/]

Not that it provides much additional context, but I originally saw the failure building Rails: http://intertwingly.net/projects/AWDwR4/checkdepot-210/


I've reproduced the problem (using rvm stable) on Ubuntu 12.10, Ubuntu 12.04, and Ubuntu 10.04


More info, in to a request from @mpapis:

$ ruby -rrbconfig -e 'puts RbConfig::CONFIG["CC"]'
@envygeeks envygeeks was assigned Mar 24, 2013
Ruby enVironment Manager member

it's an issue with ruby-head - moving to RVM 1.20 - we will fix it after RVM 1.19.0 release

@mpapis mpapis was assigned Mar 30, 2013
@mpapis mpapis closed this in 419ff82 Mar 30, 2013
Ruby enVironment Manager member

scheduled for 1.19.1

@mpapis mpapis reopened this Mar 30, 2013
@mpapis mpapis closed this in 909fc1c Mar 31, 2013
Ruby enVironment Manager member

Need to add warning when using rubygems 1.8 on ruby 2.0+

@mpapis mpapis reopened this Jul 16, 2013
@mpapis mpapis closed this Jul 17, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment