"rvm get latest-minor" should not remove default.gems file #2492

Closed
joshk opened this Issue Dec 30, 2013 · 3 comments

Comments

Projects
None yet
2 participants

joshk commented Dec 30, 2013

rvm_with_gems_default should be used, as spoken by the legend @mpapis himself.

mpapis closed this in d80282d Dec 31, 2013

Owner

mpapis commented Dec 31, 2013

so it will require 1.26 release - the accumulated changes are to big for teeny version bump, I will try to review hanging tickets and provide release tomorrow ...

till then could you give it a spin with head version? =>

rvm_without_gems="rubygems-bundler bundler"
rvm_with_default_gems="rake=~>10.1.1 bundler=~>1.5.1"
  • the = sign in rvm_with_default_gems is version separator,
  • the files in $rvm_path/gemsets will not change, the change is applied dynamically after reading the list from file, so multiple installation process does not have effect on the list.

joshk commented Jan 1, 2014

Thanks for the great fixes!
Is there a rough ETA for 1.26?

Owner

mpapis commented Jan 1, 2014

I finally decided to not bump minor, please use 1.25 I think it's 1.25.12
now

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment