RVM uses 'sort -V' which isn't available on OS X #2676

Closed
henrikhodne opened this Issue Mar 5, 2014 · 0 comments

Comments

Projects
None yet
2 participants

In selector_parse, sort -V is called, but this doesn't work on OS X since the -V flag is not available. This seems to affect fuzzy matching when installing:

$ rvm use 2.1.0 --install --binary --fuzzy
sort: invalid option -- V
Try `sort --help' for more information.
/Users/travis/.rvm/scripts/selector_parse: line 18: __list_remote_ruby_for: command not found
2.1.0 is not installed - installing.
sort: invalid option -- V
Try `sort --help' for more information.
/Users/travis/.rvm/scripts/selector_parse: line 18: __list_remote_ruby_for: command not found
Searching for binary rubies, this might take some time.
Requested binary installation but no rubies are available to download, consider skipping --binary flag.
Gemset '' does not exist,       'rvm 2.1.0 do rvm gemset create ' first, or append '--create'.

@mpapis mpapis closed this in 6e7a959 Mar 7, 2014

@mpapis mpapis added this to the rvm 1.25 milestone Mar 7, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment