New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bundler is not installed after fresh RVM installation #3366

Closed
renatojf opened this Issue Apr 2, 2015 · 5 comments

Comments

Projects
None yet
4 participants
@renatojf

renatojf commented Apr 2, 2015

I just installed RVM with

curl -L https://get.rvm.io | bash -s stable

After it, I ran the source command, installed my ruby version and when I entered the project I got this message:

The program 'bundle' is currently not installed. You can install it by typing:
sudo apt-get install bundler

I just formatted my machine and this is the first thing I'm doing in it, so my system is clean, the installation of RVM is clean and still, I can't solve this problem unless I install bundler manually. But if I install it manually, my PATH gets scrambled and I start getting warnings from RVM saying that my PATH isn't right and I should use 'rvm use version" all the time.

Can someone help me with this?

@havenwood

This comment has been minimized.

Contributor

havenwood commented Apr 2, 2015

Use the command gem install bundler to install the Bundler gem.

The apt-get gem packages are for use with the system Ruby that's installed through apt-get. To install gems for RVM Rubies first select the Ruby with rvm use ..., then gem install ... without sudo. Here's a bit of reading on RubyGems and RVM.

@renatojf

This comment has been minimized.

renatojf commented Apr 2, 2015

The thing is, according to this https://rvm.io/integration/bundler

There is no need to do anything to make bundler work with RVM

RVM automatically installs rubygems-bundler. I never had to install bundler manually to make it work.

@havenwood

This comment has been minimized.

Contributor

havenwood commented Apr 2, 2015

Bundler was introduced as a default global gem in RVM 1.9.1 but is no longer amongst the default global gems as of RVM 1.26.11.

@renatojf

This comment has been minimized.

renatojf commented Apr 8, 2015

Ok. That explains a lot.
Thank you very much.

@TigerWolf

This comment has been minimized.

TigerWolf commented Dec 15, 2015

Is there a way to add a script that will install bundler on every new ruby install?

@pkuczynski pkuczynski modified the milestone: rvm-1.27.0 Nov 8, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment