Installation of package readline fails with version 1.8.6 (on Ubuntu 11.10) #515

Closed
MMSequeira opened this Issue Oct 21, 2011 · 4 comments

Projects

None yet

3 participants

@MMSequeira

Installation with version 1.8.5 of RVM proceeds without problem. Here's the output of the instalation with RVM 1.8.6:

Fetching readline-5.2.tar.gz to /home/teste/.rvm/archives
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 1989k  100 1989k    0     0   476k      0  0:00:04  0:00:04 --:--:--  543k
Extracting readline-5.2.tar.gz to /home/teste/.rvm/src
Applying patch '/home/teste/.rvm/patches/readline-5.2/shobj-conf.patch'...
Configuring readline in /home/teste/.rvm/src/readline-5.2.
Compiling readline in /home/teste/.rvm/src/readline-5.2.
Installing readline to /home/teste/.rvm/usr
Fetching readline-6.2.tar.gz to /home/teste/.rvm/archives
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 2224k  100 2224k    0     0   546k      0  0:00:04  0:00:04 --:--:--  659k
Extracting readline-6.2.tar.gz to /home/teste/.rvm/src
Applying patch '/home/teste/.rvm/patches/readline-6.2/patch-shobj-conf.diff'...
ERROR: Error running 'patch -p0 -f < /home/teste/.rvm/patches/readline-6.2/patch-shobj-conf.diff', please read /home/teste/.rvm/log/readline/patch.log
ERROR: Patch /home/teste/.rvm/patches/readline-6.2/patch-shobj-conf.diff did not apply cleanly... back to the patching board :(
@MMSequeira

The contents of the /home/teste/.rvm/log/readline/patch.log file is:
[2011-10-21 17:58:22] patch -p0 -f < /home/teste/.rvm/patches/readline-6.2/patch-shobj-conf.diff
patching file support/shobj-conf
Hunk #1 FAILED at 157.
1 out of 2 hunks FAILED -- saving rejects to file support/shobj-conf.rej

@mpapis mpapis was assigned Oct 26, 2011
@mpapis
Member
mpapis commented Oct 26, 2011

also reproduced by @deryldoucette - https://gist.github.com/1314670

@MMSequeira

Truth be told, yesterday I realized there is no need for building the package in Ubuntu 11.10. All that is necessary is to install libreadline-gplv2-dev:

sudo apt-get install libreadline-gplv2-dev
@ddd
Contributor
ddd commented Oct 26, 2011

@mpapis the gist you used here is based on OS X. The problem affects all platforms. Its a failure of the patch itself.

@mpapis mpapis closed this in b722c0f Oct 27, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment