Error ENOENT on Ubuntu #93

Closed
MathRobin opened this Issue Dec 1, 2012 · 6 comments

Comments

Projects
None yet
5 participants

Hi, I meet an error when installing

command : ~/johnny$ npm install

npm ERR! install Couldn't read dependencies
npm ERR! Error: ENOENT, open '/home/mathrobin/johnny/package.json'
npm ERR! { [Error: ENOENT, open '/home/mathrobin/johnny/package.json']
npm ERR! errno: 34,
npm ERR! code: 'ENOENT',
npm ERR! path: '/home/mathrobin/johnny/package.json' }
npm ERR! You may report this log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com

npm ERR! System Linux 3.2.0-34-generic
npm ERR! command "node" "/usr/bin/npm" "install"
npm ERR! cwd /home/mathrobin/johnny
npm ERR! node -v v0.8.9
npm ERR! npm -v 1.1.26
npm ERR! path /home/mathrobin/johnny/package.json
npm ERR! code ENOENT
npm ERR! message ENOENT, open '/home/mathrobin/johnny/package.json'
npm ERR! errno 34
npm ERR! 34 errno
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/mathrobin/johnny/npm-debug.log
npm ERR! not ok code 0

I don't know what to do more. Thanks in advance

Collaborator

paultag commented Dec 1, 2012

Could you please paste an ls of your current directory? It sounds like you're not in the right directory :)

You're true, not in the right directory. But get this error now

command : npm install

npm ERR! Error: No compatible version found: uglify-js@'>=1.3.3- <1.4.0-'
npm ERR! Valid install targets:
npm ERR! ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7","1.1.0","1.1.1","1.2.0","1.2.1","1.2.2","1.2.3","1.2.4","1.2.5","1.2.6","1.3.0","1.3.1","1.3.2"]
npm ERR! at installTargetsError (/usr/lib/node_modules/npm/lib/cache.js:506:10)
npm ERR! at next_ (/usr/lib/node_modules/npm/lib/cache.js:452:17)
npm ERR! at next (/usr/lib/node_modules/npm/lib/cache.js:427:44)
npm ERR! at /usr/lib/node_modules/npm/lib/cache.js:419:5
npm ERR! at saved (/usr/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:136:7)
npm ERR! at /usr/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:230:7
npm ERR! at Object.oncomplete (fs.js:297:15)
npm ERR! [Error: No compatible version found: uglify-js@'>=1.3.3- <1.4.0-'
npm ERR! Valid install targets:
npm ERR! ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7","1.1.0","1.1.1","1.2.0","1.2.1","1.2.2","1.2.3","1.2.4","1.2.5","1.2.6","1.3.0","1.3.1","1.3.2"]]
npm ERR! You may report this log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com

npm ERR! System Linux 3.2.0-34-generic
npm ERR! command "node" "/usr/bin/npm" "install"
npm ERR! cwd /home/mathrobin/johnny/johnny-five
npm ERR! node -v v0.8.9
npm ERR! npm -v 1.1.26
npm ERR! message No compatible version found: uglify-js@'>=1.3.3- <1.4.0-'
npm ERR! message Valid install targets:
npm ERR! message ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","1.0.1","1.0.2","1.0.3","1.0.4","1.0.5","1.0.6","1.0.7","1.1.0","1.1.1","1.2.0","1.2.1","1.2.2","1.2.3","1.2.4","1.2.5","1.2.6","1.3.0","1.3.1","1.3.2"]

lodash@0.10.0 install /home/mathrobin/johnny/johnny-five/node_modules/lodash
node build/post-install

ws@0.4.20 install /home/mathrobin/johnny/johnny-five/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws
node install.js

[ws v0.4.20] Attempting to compile blazing fast native extensions.
[ws v0.4.20] Native extension compilation successful!
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/mathrobin/johnny/johnny-five/npm-debug.log
npm ERR! not ok code 0

Owner

rwaldron commented Dec 1, 2012

Installing Johnny-Five from npm has been problematic since Serialport updated to node-gyp. For now, I'd recommend just cloning the repo

Owner

rwaldron commented Jun 16, 2013

@MathRobin is this still an issue?

Contributor

julianduque commented Aug 9, 2013

I'm using Ubuntu and Installing johnny-five from npm is working like a charm

Collaborator

divanvisagie commented Aug 23, 2013

@julianduque In that case this looks like a close. Thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment