Permalink
Browse files

avoid appscript related module graph errors in Ruby 1.8 by loading ap…

…pscript as early as possible

("module Blah has been removed from the module tree, but is still active")
  • Loading branch information...
1 parent 53c8191 commit 43da2dc7b32275ea1ac9196cbe3d8d394b8d9d68 @rwilcox committed with elia Sep 19, 2010
Showing with 2 additions and 1 deletion.
  1. +2 −1 tap.rb
View
3 tap.rb
@@ -10,6 +10,8 @@
gem 'rb-appscript'
gem 'sinatra'
+require 'appscript'
+
$LOAD_PATH.unshift File.expand_path("~/Code/tap")
if ARGV.include? '-f'
@@ -66,7 +68,6 @@
class MateError < StandardError
end
- require 'appscript'
include Appscript
last = nil
File.open(File.expand_path("#{ROOT}/.tap_history"), 'a') do |history|

0 comments on commit 43da2dc

Please sign in to comment.