Permalink
Browse files

Update to Ember 1.10.0.

  • Loading branch information...
rwjblue committed Feb 9, 2015
1 parent 9de082a commit 78e7ed2d072f42d9cf0fd3d9fc2376f106ab762e
Showing with 7 additions and 4 deletions.
  1. +5 −1 Brocfile.js
  2. +1 −2 bower.json
  3. +1 −1 package.json
View
@@ -2,7 +2,11 @@
var EmberApp = require('ember-cli/lib/broccoli/ember-app');
var app = new EmberApp();
var app = new EmberApp({
vendorFiles: {
'handlebars.js': null
}

This comment has been minimized.

Show comment
Hide comment
@seanpdoyle

seanpdoyle Feb 10, 2015

What's the reasoning behind this?

@seanpdoyle

seanpdoyle Feb 10, 2015

What's the reasoning behind this?

This comment has been minimized.

Show comment
Hide comment
@rwjblue

rwjblue Feb 10, 2015

Owner

To prevent handlebars from being loaded into vendor.js.

@rwjblue

rwjblue Feb 10, 2015

Owner

To prevent handlebars from being loaded into vendor.js.

This comment has been minimized.

Show comment
Hide comment
@seanpdoyle

seanpdoyle Feb 10, 2015

Removing the handlebars dependency from the bower.json won't do that?

@seanpdoyle

seanpdoyle Feb 10, 2015

Removing the handlebars dependency from the bower.json won't do that?

This comment has been minimized.

Show comment
Hide comment
@rwjblue

rwjblue Feb 10, 2015

Owner

No, in ember-cli 0.1.12 it will still try to app.import it.

@rwjblue

rwjblue Feb 10, 2015

Owner

No, in ember-cli 0.1.12 it will still try to app.import it.

This comment has been minimized.

Show comment
Hide comment
@seanpdoyle

seanpdoyle Feb 10, 2015

screen shot 2015-02-10 at 1 38 48 pm

This is what I get for not believing you.

@seanpdoyle

seanpdoyle Feb 10, 2015

screen shot 2015-02-10 at 1 38 48 pm

This is what I get for not believing you.

This comment has been minimized.

Show comment
Hide comment
@rwjblue

rwjblue Feb 10, 2015

Owner

LOL, I did tell you. 😜

@rwjblue

rwjblue Feb 10, 2015

Owner

LOL, I did tell you. 😜

This comment has been minimized.

Show comment
Hide comment
@jclem

jclem Feb 13, 2015

As of at least Ember CLI 0.1.15, this is no longer necessary.

I'm wrong—thanks, @rwjblue.

@jclem

jclem Feb 13, 2015

As of at least Ember CLI 0.1.15, this is no longer necessary.

I'm wrong—thanks, @rwjblue.

This comment has been minimized.

Show comment
Hide comment
@rwjblue

rwjblue Feb 13, 2015

Owner

@jclem - All Ember CLI 0.1.x versions will need this change to prevent Handlebars from being added to vendor.js.

@rwjblue

rwjblue Feb 13, 2015

Owner

@jclem - All Ember CLI 0.1.x versions will need this change to prevent Handlebars from being added to vendor.js.

});
// Use `app.import` to add additional libraries to the generated
// output files.
View
@@ -1,9 +1,8 @@
{
"name": "components-in-subdirs",
"dependencies": {
"handlebars": "~1.3.0",
"jquery": "^1.11.1",
"ember": "1.8.1",
"ember": "1.10.0",
"ember-data": "1.0.0-beta.14.1",
"ember-resolver": "~0.1.11",
"loader.js": "ember-cli/loader.js#1.0.1",
View
@@ -20,12 +20,12 @@
"license": "MIT",
"devDependencies": {
"broccoli-asset-rev": "^2.0.0",
"broccoli-ember-hbs-template-compiler": "^1.6.1",
"ember-cli": "0.1.12",
"ember-cli-6to5": "^3.0.0",
"ember-cli-app-version": "0.3.1",
"ember-cli-content-security-policy": "0.3.0",
"ember-cli-dependency-checker": "0.0.7",
"ember-cli-htmlbars": "^0.6.0",
"ember-cli-ic-ajax": "0.1.1",
"ember-cli-inject-live-reload": "^1.3.0",
"ember-cli-qunit": "0.3.3",

5 comments on commit 78e7ed2

@jamiechong

This comment has been minimized.

Show comment
Hide comment
@jamiechong

jamiechong Feb 16, 2015

Hi, I'm new to both Ember and Ember-CLI so perhaps I'm out to lunch here... but it looks like
ember-cli-htmlbars has a latest version of 0.7.4 whereas the above change to package.json only installs 0.6.0. Any reason to not use the latest?

jamiechong replied Feb 16, 2015

Hi, I'm new to both Ember and Ember-CLI so perhaps I'm out to lunch here... but it looks like
ember-cli-htmlbars has a latest version of 0.7.4 whereas the above change to package.json only installs 0.6.0. Any reason to not use the latest?

@rwjblue

This comment has been minimized.

Show comment
Hide comment
@rwjblue

rwjblue Feb 16, 2015

Owner

@jamiechong - At the time this commit was made, 0.6.0 was the latest version. You should definitely use 0.7.x.

Owner

rwjblue replied Feb 16, 2015

@jamiechong - At the time this commit was made, 0.6.0 was the latest version. You should definitely use 0.7.x.

@zekefast

This comment has been minimized.

Show comment
Hide comment
@zekefast

zekefast Mar 16, 2015

It looks like ember 1.10.0 requires node 0.8.x or 0.10.x, incompatible with node 0.12.0.

$ npm install
npm WARN deprecated 6to5-core@2.13.7: 6to5 is now 'babel': https://babeljs.io/blog/2015/02/15/not-born-to-die
npm WARN engine ember-script@0.0.14: wanted: {"node":"0.8.x || 0.10.x"} (current: {"node":"0.12.0","npm":"2.5.1"})

zekefast replied Mar 16, 2015

It looks like ember 1.10.0 requires node 0.8.x or 0.10.x, incompatible with node 0.12.0.

$ npm install
npm WARN deprecated 6to5-core@2.13.7: 6to5 is now 'babel': https://babeljs.io/blog/2015/02/15/not-born-to-die
npm WARN engine ember-script@0.0.14: wanted: {"node":"0.8.x || 0.10.x"} (current: {"node":"0.12.0","npm":"2.5.1"})
@rwjblue

This comment has been minimized.

Show comment
Hide comment
@rwjblue

rwjblue Mar 16, 2015

Owner

@zekefast - This message is from ember-script and is not related to ember itself or ember-cli (which supports Node 0.12 and IO.js).

Owner

rwjblue replied Mar 16, 2015

@zekefast - This message is from ember-script and is not related to ember itself or ember-cli (which supports Node 0.12 and IO.js).

@zekefast

This comment has been minimized.

Show comment
Hide comment
@zekefast

zekefast Mar 16, 2015

@rwjblue, Oh, sorry, my omission!

zekefast replied Mar 16, 2015

@rwjblue, Oh, sorry, my omission!

Please sign in to comment.