Skip to content


missing deps for Digest::SHA1? #6

tokuhirom opened this Issue · 3 comments

2 participants


t/module_info.t fails under the plain perl5.8.2 with this message:

t/module_info.t ........ 1/? Can't locate Digest/ in @INC (@INC contains: /Users/tokuhirom/.cpanm/work/1360277710.24728/Dist-Metadata-0
.924/blib/lib /Users/tokuhirom/.cpanm/work/1360277710.24728/Dist-Metadata-0.924/blib/arch /Users/tokuhirom/.plenv/versions/5.8.2/lib/perl5/5.8
.2/darwin-2level /Users/tokuhirom/.plenv/versions/5.8.2/lib/perl5/5.8.2 /Users/tokuhirom/.plenv/versions/5.8.2/lib/perl5/site_perl/5.8.2/darwi
n-2level /Users/tokuhirom/.plenv/versions/5.8.2/lib/perl5/site_perl/5.8.2 /Users/tokuhirom/.plenv/versions/5.8.2/lib/perl5/site_perl .) at (ev
al 92) line 3.

I guess you forgot to add a Digest::SHA1 as dependency.


What version of 'Digest' do you have installed on that machine?

Looking at the change log for 'Digest' I might need to bump the required version of that.


perl -MDigest\ 9
Digest version 9 required--this is only version 1.02.

It's 10 years old!

@rwstauner rwstauner closed this in 6701fe0

Apparently this is only an issue for perls < 5.8.3:

*$ corelist -a Digest | head

Data for 2013-01-20
Digest was first released with perl v5.7.3
  v5.7.3     1.00      
  v5.8.0     1.00      
  v5.8.1     1.02      
  v5.8.2     1.02      
  v5.8.3     1.05      
@rwstauner rwstauner added a commit that referenced this issue
@rwstauner v0.925
  - Specify 1.03 as minimum required version of Digest
    to ensure that it tries Digest::SHA.  Closes gh-6.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.