Permalink
Browse files

Merge pull request #8 from sj26/remove-engine

Remove engine
  • Loading branch information...
2 parents 346128d + affc5fe commit 8c90dcb103fc0ef8257c9b8b4ddd7d9a9cbd8616 @rwz committed Jul 16, 2013
View
@@ -1,4 +1,6 @@
-require 'nestive/engine'
+require 'nestive/version'
+require 'nestive/layout_helper'
+require 'nestive/railtie'
module Nestive
-end
+end
View
@@ -1,6 +0,0 @@
-if defined?(Rails) && Rails.version.to_i >= 3
- module Nestive
- class Engine < Rails::Engine
- end
- end
-end
File renamed without changes.
View
@@ -13,9 +13,8 @@ Gem::Specification.new do |s|
s.description = 'A Rails plugin/gem for awesome nested templates and layouts'
s.licenses = ['MIT']
-
- s.files = `git ls-files`.split("\n")
- s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.files = Dir["README.md", "MIT-LICENSE", "lib/**/*"]
+ s.test_files = Dir["spec/**/*"]
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ['lib']
@@ -1,3 +1,3 @@
Rails.application.routes.draw do
- match ':controller/:action'
+ get ':controller/:action'
end
View
@@ -1,9 +1,8 @@
-require 'bundler/setup'
require 'rails'
require 'combustion'
-require File.expand_path('../../lib/nestive', __FILE__)
+require 'nestive'
Combustion.initialize! :action_controller
-require 'rspec/rails'
+require 'rspec/rails'

0 comments on commit 8c90dcb

Please sign in to comment.