Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

simplifying .rvmrc

  • Loading branch information...
commit bcf2756ad279d9dc5b6a0b50ef3114f3e851322c 1 parent 52435e9
Ryan Bates authored
Showing with 2 additions and 24 deletions.
  1. +1 −23 .rvmrc
  2. +1 −1  Gemfile
24 .rvmrc
View
@@ -1,23 +1 @@
-#!/usr/bin/env bash
-
-# adapted from: http://rvm.beginrescueend.com/workflow/rvmrc/
-
-ruby_string="1.8.7"
-gemset_name="cancan"
-
-if rvm list strings | grep -q "${ruby_string}" ; then
-
- # Load or create the specified environment
- if [[ -d "${rvm_path:-$HOME/.rvm}/environments" \
- && -s "${rvm_path:-$HOME/.rvm}/environments/${ruby_string}@${gemset_name}" ]] ; then
- \. "${rvm_path:-$HOME/.rvm}/environments/${ruby_string}@${gemset_name}"
- else
- rvm --create "${ruby_string}@${gemset_name}"
- fi
-
-else
-
- # Notify the user to install the desired interpreter before proceeding.
- echo "${ruby_string} was not found, please run 'rvm install ${ruby_string}' and then cd back into the project directory."
-
-fi
+rvm use 1.8.7@cancan --create
2  Gemfile
View
@@ -2,7 +2,7 @@ source "http://rubygems.org"
case ENV["MODEL_ADAPTER"]
when nil, "active_record"
- gem "sqlite3-ruby", :require => "sqlite3"
+ gem "sqlite3"
gem "activerecord", :require => "active_record"
gem "with_model"
gem "meta_where"
Please sign in to comment.
Something went wrong with that request. Please try again.