Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

rake test - stack level too deep (SystemStackError) #12

Closed
jeffkreeftmeijer opened this Issue · 6 comments

2 participants

@jeffkreeftmeijer

all of a sudden I started getting this error when trying to run rake test:
http://gist.github.com/151904.

@ryanb
Owner

Were you ever able to solve this issue? I know the tests could use some improving.

@jeffkreeftmeijer

Nope, I've never solved it.

@ryanb
Owner

I know the tests in general can use a lot of work. I would like to get cucumber setup to run the generators and then run the tests that the generators create (I believe Dr. Nic came up with this solution). Someday soon hopefully.

@jeffkreeftmeijer

Strange, I checked again (on my macbook) and the tests seem to work now. I'll check if it has anything to do with the versions of the gems I'm using. Stay tuned :)

@jeffkreeftmeijer

Ok, got it working.

It only works with shoulda <= v2.0.6

That's about all I can tell you...

@ryanb
Owner

being more explicit about which versions of shoulda and rubigen to use to get tests running - closed by 3848cee

@dblanken dblanken referenced this issue from a commit
@ryanb being more explicit about which versions of shoulda and rubigen to us…
…e to get tests running - closes #12
3848cee
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.