Skip to content
Browse files

Merge pull request #5 from elandesign/master

Added gemspec and moved tasks
  • Loading branch information...
2 parents da34c4a + b03d733 commit f9154144e64c6bf18360bba4eddd6d5d1b60341d @ryanb committed Jun 29, 2011
Showing with 16 additions and 1 deletion.
  1. +1 −0 .gitignore
  2. +1 −1 Rakefile
  3. 0 { → lib}/tasks/spec.rb
  4. 0 { → rails}/init.rb
  5. +14 −0 trusted_params.gemspec
View
1 .gitignore
@@ -0,0 +1 @@
+*.gem
View
2 Rakefile
@@ -1,4 +1,4 @@
require 'rubygems'
require 'rake'
-Dir["#{File.dirname(__FILE__)}/tasks/*.rb"].sort.each { |ext| load ext }
+Dir["#{File.dirname(__FILE__)}/lib/tasks/*.rb"].sort.each { |ext| load ext }
View
0 tasks/spec.rb → lib/tasks/spec.rb
File renamed without changes.
View
0 init.rb → rails/init.rb
File renamed without changes.
View
14 trusted_params.gemspec
@@ -0,0 +1,14 @@
+Gem::Specification.new do |s|
+ s.name = "trusted_params"
+ s.version = "1.0.0"
+ s.author = "Ryan Bates"
+ s.email = "ryan@railscasts.com"
+ s.homepage = "http://github.com/ryanb/trusted-params"
+ s.summary = "Rails plugin which adds a convenient way to override attr_accessible protection."
+
+ s.files = Dir["{lib,spec,rails}/**/*", "[A-Z]*"]
+ s.require_path = "lib"
+
+ s.rubyforge_project = s.name
+ s.required_rubygems_version = ">= 1.3.4"
+end

0 comments on commit f915414

Please sign in to comment.
Something went wrong with that request. Please try again.