Skip to content
Browse files

Update support files

  • Loading branch information...
1 parent 8f6b192 commit f6003faaf6b6ecd69a624e032c84581d39511f2d @ryanbooker committed
Showing with 37 additions and 23 deletions.
  1. +6 −0 CHANGELOG
  2. +0 −22 README
  3. +30 −0 README.rdoc
  4. +1 −1 VERSION
View
6 CHANGELOG
@@ -1,5 +1,11 @@
----------------------------------------------------------------
+0.5.4 - 15.06.2009
+
+* Fixed Gem spec loading
+
+----------------------------------------------------------------
+
0.5.3 - 29.05.2007
* Added a bit of Config::CONFIG magic to make RubyScript2Exe
View
22 README
@@ -1,22 +0,0 @@
-----------------------------------------------------------------
-
-RubyScript2Exe transforms your Ruby script into a standalone,
-compressed Windows, Linux or Mac OS X (Darwin) executable. You
-can look at it as a "compiler". Not in the sense of a
-source-code-to-byte-code compiler, but as a "collector", for it
-collects all necessary files to run your script on an other
-machine: the Ruby script, the Ruby interpreter and the Ruby
-runtime library (stripped down for this script). Anyway, the
-result is the same: a standalone executable (application.exe).
-And that's what we want!
-
-For more information, see
-http://www.erikveen.dds.nl/rubyscript2exe/index.html .
-
-----------------------------------------------------------------
-
-The best way to use Tar2RubyScript is the RB, not this TAR.GZ.
-The latter is just for playing with the internals. Both are
-available on the site.
-
-----------------------------------------------------------------
View
30 README.rdoc
@@ -0,0 +1,30 @@
+= RubyScript2Exe
+
+Original Code: http://www.erikveen.dds.nl/rubyscript2exe
+
+RubyScript2Exe compiles your application's Ruby script archive
+(created with Tar2RubyScript) into a standalone compressed
+Windows, Linux or Mac OS X (Darwin) executable. You
+can look at it as a "compiler". Not in the sense of a
+source-code-to-byte-code compiler, but as a "collector", for it
+collects all necessary files to run your script on another
+machine: the Ruby script, the Ruby interpreter and the Ruby
+runtime library (stripped down for this script).
+
+
+== Updated to handle Ruby 1.8.7
+
+require2lib.rb has been updated so that gem specs are now loaded via
+Gem.loaded_specs rather than via Gem::Specifications.list.
+
+I've released this as it appears the original project is no longer
+being maintained. Feel free to pull this into any authoratative
+branch that may exist.
+
+
+== Building
+
+To build the repository you need to use Tar2RubyScript
+http://github.com/ryanbooker/tar2rubyscript:
+
+ ruby tar2rubyscript.rb rubyscript2exe/
View
2 VERSION
@@ -1 +1 @@
-0.5.3
+0.5.4

0 comments on commit f6003fa

Please sign in to comment.
Something went wrong with that request. Please try again.