Permalink
Browse files

Add login message about this version being from old respository, with…

… link to new repository.
  • Loading branch information...
1 parent 19963a5 commit 0f20b071a548cf3138fd5ab827ecf87275eea94a @ryancramerdesign committed Oct 7, 2016
Showing with 8 additions and 1 deletion.
  1. +1 −1 wire/core/ProcessWire.php
  2. +2 −0 wire/core/Wire.php
  3. +5 −0 wire/modules/Process/ProcessLogin/ProcessLogin.module
@@ -37,7 +37,7 @@ class ProcessWire extends Wire {
const versionMajor = 2;
const versionMinor = 7;
const versionRevision = 3;
- const versionSuffix = 'dev';
+ const versionSuffix = '';
const indexVersion = 270; // required version for index.php file (represented by PROCESSWIRE define)
const htaccessVersion = 250; // required version for .htaccess file
View
@@ -84,6 +84,8 @@
*/
protected $useFuel = true;
+ public function __construct() {}
+
/**
* Add fuel to all classes descending from Wire
*
@@ -251,6 +251,11 @@ class ProcessLogin extends Process {
$indexVersion = ProcessWire::indexVersion;
$htaccessVersion = ProcessWire::htaccessVersion;
+ $this->warning(
+ "Please note: This version of ProcessWire is from the old repository. The new repositories are located at: " .
+ "<a target='_blank' href='https://github.com/processwire/'>github.com/processwire</a>", Notice::allowMarkup
+ );
+
if(PROCESSWIRE < $indexVersion) {
$this->warning(
"Not urgent, but note that your root index.php file is not up-to-date with this ProcessWire version - please update it when possible. " .

1 comment on commit 0f20b07

Why is there no 2.7.3 on the new github account? We don't want to use 2.8 or 3.

Please sign in to comment.