Skip to content
「Raspberry Piで学ぶ ROSロボット入門」の情報ポータル
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
trouble_reports Fix Jun 15, 2018
README.bkup [CREATED][MODIFY] Created a file README.md which is the english versi… Jan 7, 2019
README.md Update README.md Aug 15, 2019
README_en.md [MODIFY] Realized there was a specification of the filename. Jan 7, 2019
errata.md Update errata.md Nov 14, 2018
faq.md Update faq.md May 1, 2017
os_images.md Update os_images.md Dec 23, 2017
references.md
ubuntu18.md Fix the package name Jul 9, 2019

README.md

「Raspberry Piで学ぶ ROSロボット入門」の情報リポジトリ

重要な情報

2019/8/15

Travis CIでのテストで使うUbuntuを14.04から16.04にアップデートしました。

2019/6/18

Ubuntu 18.04を使う場合の情報を掲載しました。

2019/6/17

ROSをインストールしたりアップデートしたりするときに、GPGキーのアップデートが必要になりました。

sudo apt-key adv --keyserver 'hkp://keyserver.ubuntu.com:80' --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654

を実行してください。

2018/11/20

テストについて一点、確証のない補足があります。大抵は大丈夫なので見落としていたのですが、テストコードでダミーのデバイスに字を書き込んだら、すぐにf.flush()しないと、ファイルへの書き込みが遅延して、たまにテストがコケるような気がしてきました。

2018/6/15

https://wiki.ubuntu.com/ARM/RaspberryPi#Wifi にある手順でWiFiの動くファームウェアがインストールできることを確認しました。-> wifiproblem.md

2018/6/11

最新のROSをインストールして catkin_create_pkg を使うと、package.xml のフォーマットがバージョン2になります。このバージョンでは run_dependexec_depend に変更になっていますので、バージョン2を使うときは書籍中の run_dependexec_depend に読み替えてください。元のバージョンを使いたい時には、XML上部にある format="2"を消します。ただ、新しいほうを覚えた方が良いでしょう。

2018/5/26

ちょっと気づいてなかったのですが、WiFiが2017/5/6の方法では動作しないことに気づきました。調査中です。とりあえず解決までは、次のようにおねがいします。

  • 今、インストールが済んでWiFiが使えている場合はapt upgradeしない。
  • これからインストールするときは、このイメージを利用

2018/4/22

執筆当時のシミュレータ(E章)の状況が残っていなかったので、その当時のもののブランチを作っていただきました。

2017/12/18

10章において、xmlファイルが指定したパスにないことが原因で、OpenCVにエラーが出ることがあります。

  • 対処法

以下のコマンドを実行お願いします。

$ sudo apt install opencv-data

2017/12/8

12章で使うJavaScriptへのコードがリンク切れ状態になっています。

デバイスドライバにバグがありましたので修正しました。(2017/7/7)

2017/5/6

カーネルをアップデートするとWiFiが使えないという不具合を確認しています。

その他の情報

各章のリポジトリ

便利ツール

You can’t perform that action at this time.