Permalink
Browse files

Update libconfuse to v3.0.

Change-Id: I4be400311bc4877eec2105b410cb2e67f268a23c
  • Loading branch information...
xyzsam committed Apr 13, 2016
1 parent 9d72952 commit a981034d1c592ce2192fe0ebd3ac344a7b2facb8
Showing with 78 additions and 70 deletions.
  1. +2 −2 WORKSPACE
  2. +1 −1 third_party/confuse/BUILD.external
  3. +7 −7 third_party/confuse/config.h
  4. +68 −60 third_party/confuse/lexer.c
View
@@ -14,8 +14,8 @@ new_http_archive(
new_http_archive(
name = "confuse",
- url = "https://github.com/martinh/libconfuse/archive/v2.8.zip",
- sha256 = "34543ccff48b853241bac57dce8353bfc2c9b01d49b51f9cd6619d4a946fa5ef",
+ url = "https://github.com/martinh/libconfuse/releases/download/v3.0/confuse-3.0.tar.gz",
+ sha256 = "f1f326d9443103036d19c32d3f3efec3a85c3b081d99534463668d29992c4648",
build_file = "third_party/confuse/BUILD.external",
)
@@ -1,6 +1,6 @@
licenses(["notice"])
-CONFUSE_PATH = "libconfuse-2.8"
+CONFUSE_PATH = "confuse-3.0"
cc_library(
visibility = ["//visibility:public"],
@@ -5,11 +5,11 @@
language is requested. */
/* #define ENABLE_NLS 1 */
-/* Define to 1 if you have the MacOS X function CFLocaleCopyCurrent in the
+/* Define to 1 if you have the Mac OS X function CFLocaleCopyCurrent in the
CoreFoundation framework. */
/* #undef HAVE_CFLOCALECOPYCURRENT */
-/* Define to 1 if you have the MacOS X function CFPreferencesCopyAppValue in
+/* Define to 1 if you have the Mac OS X function CFPreferencesCopyAppValue in
the CoreFoundation framework. */
/* #undef HAVE_CFPREFERENCESCOPYAPPVALUE */
@@ -23,7 +23,7 @@
/* Define if the GNU gettext() function is already present or preinstalled. */
#define HAVE_GETTEXT 1
-/* Define if you have the iconv() function. */
+/* Define if you have the iconv() function and it works. */
/* #undef HAVE_ICONV */
/* Define to 1 if you have the <inttypes.h> header file. */
@@ -85,7 +85,7 @@
#define PACKAGE_NAME "libConfuse"
/* Define to the full name and version of this package. */
-#define PACKAGE_STRING "libConfuse 2.8"
+#define PACKAGE_STRING "libConfuse 3.0"
/* Define to the one symbol short name of this package. */
#define PACKAGE_TARNAME "confuse"
@@ -94,17 +94,17 @@
#define PACKAGE_URL ""
/* Define to the version of this package. */
-#define PACKAGE_VERSION "2.8"
+#define PACKAGE_VERSION "3.0"
/* Define to 1 if you have the ANSI C header files. */
#define STDC_HEADERS 1
/* Version number of package */
-#define VERSION "2.8"
+#define VERSION "3.0"
/* Define to 1 if `lex' declares `yytext' as a `char *' by default, not a
`char[]'. */
-#define YYTEXT_POINTER 1
+/* #undef YYTEXT_POINTER */
/* Define to empty if `const' does not conform to ANSI C. */
/* #undef const */
Oops, something went wrong.

0 comments on commit a981034

Please sign in to comment.