Permalink
Browse files

bundling in http://github.com/AaronH/chronic for ruby 1.9.2 compatibi…

…lity
  • Loading branch information...
1 parent 3e20f93 commit 4fc6a10dad54ae3e90e02ca731eed92429218b01 @javan javan committed Sep 10, 2010
Showing with 9 additions and 2 deletions.
  1. +3 −0 .gitmodules
  2. +0 −1 Rakefile
  3. +5 −1 lib/whenever.rb
  4. +1 −0 lib/whenever/vendor/gems/chronic
View
@@ -0,0 +1,3 @@
+[submodule "lib/whenever/vendor/gems/chronic"]
+ path = lib/whenever/vendor/gems/chronic
+ url = git://github.com/AaronH/chronic.git
View
@@ -13,7 +13,6 @@ begin
gemspec.email = "javan@javan.us"
gemspec.homepage = "http://github.com/javan/whenever"
gemspec.authors = ["Javan Makhmali"]
- gemspec.add_dependency 'chronic', '>= 0.2.3'
gemspec.add_dependency 'activesupport', '>= 2.3.4'
gemspec.add_development_dependency 'shoulda', '>= 2.1.1'
gemspec.add_development_dependency 'mocha', '>= 0.9.5'
View
@@ -1,6 +1,10 @@
-require 'chronic'
require 'active_support/all'
+# Bundling in http://github.com/AaronH/chronic because
+# it's compatible with Ruby 1.9.2 and the official
+# gem isn't. I hope to remove this eventually.
+require 'whenever/vendor/gems/chronic/lib/chronic'
+
require 'whenever/base'
require 'whenever/job_list'
require 'whenever/job'
Submodule chronic added at d027ad

0 comments on commit 4fc6a10

Please sign in to comment.