Skip to content
Permalink
Browse files
[packaging] Do not require usb-moded-diagnostics-config. JB#36669
Whether and what kind of diagnostic mode is supported varies from one
device to another. Having usb-moded itself depend on diagnostic mode
configuration package causes unnecessary / potentially altogether
wrong data to get installed on all devices.

Remove dependencies from main usb-moded package to diagnostic mode
configuration package.

Signed-off-by: Simo Piiroinen <simo.piiroinen@jollamobile.com>
  • Loading branch information
spiiroin committed Oct 18, 2016
1 parent 058cc3e commit 5346c2f988a2be0e29e267899b4acba779403914
Showing with 0 additions and 1 deletion.
  1. +0 −1 rpm/usb-moded.spec
@@ -18,7 +18,6 @@ BuildRequires: pkgconfig(libsystemd-daemon)

Requires: lsof
Requires: usb-moded-configs
Requires: usb-moded-diagnostics-config
Requires: busybox-symlinks-dhcp
Requires(post): systemd
Requires(postun): systemd

0 comments on commit 5346c2f

Please sign in to comment.