Skip to content
Permalink
Browse files

Add testing for Python 3.8 and remove 3.5

  • Loading branch information
saimn committed Jan 4, 2020
1 parent 42b362a commit 1b27cc3258aed26821fa7ae9937b46e001f04682
Showing with 12 additions and 15 deletions.
  1. +5 −5 .travis.yml
  2. +2 −2 setup.cfg
  3. +2 −2 setup.py
  4. +0 −3 sigal/__init__.py
  5. +3 −3 tox.ini
@@ -4,30 +4,30 @@ dist: xenial

matrix:
include:
- python: 3.5
- python: 3.6
before_install:
- sudo add-apt-repository ppa:mc3man/xerus-media -y
- sudo apt-get update -qq
- sudo apt-get install -qq ubuntu-restricted-extras ffmpeg
before_script:
ffmpeg --help
- python: 3.6
- python: 3.7
before_install:
- sudo add-apt-repository ppa:mc3man/xerus-media -y
- sudo apt-get update -qq
- sudo apt-get install -qq ubuntu-restricted-extras ffmpeg
before_script:
ffmpeg --help
- python: 3.7
- python: 3.8
before_install:
- sudo add-apt-repository ppa:mc3man/xerus-media -y
- sudo apt-get update -qq
- sudo apt-get install -qq ubuntu-restricted-extras ffmpeg
before_script:
ffmpeg --help
- python: 3.6
- python: 3.8
env: TOXENV=doc
- python: 3.6
- python: 3.8
env: TOXENV=check
allow_failures:
- env: TOXENV=check
@@ -14,9 +14,9 @@ classifiers =
License :: OSI Approved :: MIT License
Operating System :: OS Independent
Programming Language :: Python :: 3
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Topic :: Internet :: WWW/HTTP
Topic :: Multimedia :: Graphics :: Viewers
Topic :: Software Development :: Libraries :: Python Modules
@@ -25,7 +25,7 @@ classifiers =
zip_safe = False
include_package_data = True
packages = find:
python_requires = >=3.5
python_requires = >=3.6
setup_requires =
setuptools_scm
install_requires =
@@ -1,7 +1,7 @@
import sys
from setuptools import setup

if sys.version_info[:2] < (3, 5):
sys.exit('Sigal supports Python 3.5+ only')
if sys.version_info[:2] < (3, 6):
sys.exit('Sigal supports Python 3.6+ only')

setup(use_scm_version=True)
@@ -46,9 +46,6 @@

_DEFAULT_CONFIG_FILE = 'sigal.conf.py'

if sys.version_info[:2] < (3, 5):
raise Exception('Sigal supports Python 3.5+ only')


@click.group()
@click.version_option(version=__version__)
@@ -1,12 +1,12 @@
[tox]
envlist = py{35,36,37}
envlist = py{36,37,38}
skip_missing_interpreters = True

[travis]
python =
3.7: py37
3.6: py36
3.5: py35
3.7: py37
3.8: py38

[testenv]
deps =

0 comments on commit 1b27cc3

Please sign in to comment.
You can’t perform that action at this time.