New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Videos on Iphone/Ipad #196

Closed
ThomasRgbg opened this Issue Mar 3, 2016 · 7 comments

Comments

2 participants
@ThomasRgbg

ThomasRgbg commented Mar 3, 2016

Hi,

in the config it is possible to encode videos as mp4 instead of webm. This would allow to see this videos also on Safari-devices. However, there some issues: (using the galleria theme)

  • Obviously, the mime-type is always: type='video/webm'
  • But the html tags cause also some problems. What I found on the Internet, the html should look like here: http://www.justinwhall.com/html5-video-playing-ios-devices
    I tried to play around with the index.html a bit, but I think the theme makes it more complicated...
@saimn

This comment has been minimized.

Owner

saimn commented Mar 3, 2016

For the galleria theme the mime type is hard-coded, this is easy to fix:
https://github.com/saimn/sigal/blob/master/sigal/themes/colorbox/templates/index.html#L87
https://github.com/saimn/sigal/blob/master/sigal/themes/galleria/templates/index.html#L150
But I don't understand your second point, the HTML in your link is similar to the one used in the templates, so ?

@ThomasRgbg

This comment has been minimized.

ThomasRgbg commented Mar 4, 2016

What I mean is, it seems the Safari browser expects a syntax like:

<video controls> <source src="movie.mp4" type='video/mp4'> </video>

But in https://github.com/saimn/sigal/blob/master/sigal/themes/galleria/templates/index.html#L147 - 149 is also the filename referenced and this might confuse the browser ?

At least only changing the mime type don't fix the issue. But after trying around, one time the video was played, when I was heavily scrolling between the pictures/videos. I'm not an expert, but I guess it might be related with the additional file references ?

saimn added a commit that referenced this issue Mar 5, 2016

@saimn

This comment has been minimized.

Owner

saimn commented Mar 5, 2016

I fixed the mime-type, but I don't understand the filename issue: <source src='{{ media.filename }}' ... will generate the same line as the one from your example, there is no "additional file references".

@saimn saimn added this to the 1.1.0 milestone Mar 7, 2016

@ThomasRgbg

This comment has been minimized.

ThomasRgbg commented Mar 19, 2016

The <video.....> sequence is within the data-layer tag. I think Safari has difficulties to interpret this.

@saimn

This comment has been minimized.

Owner

saimn commented Mar 20, 2016

The sequence is within the data-layer tag

Sorry but I don't understand ?

@saimn

This comment has been minimized.

Owner

saimn commented Apr 24, 2016

Just released version 1.1.0, please check and reopen if the issue is still there.

@saimn saimn closed this Apr 24, 2016

@ThomasRgbg

This comment has been minimized.

ThomasRgbg commented Apr 25, 2016

Works, thanks a lot!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment