Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Customer Portal Welcome Email Blank #3261

Closed
nbouwsma opened this issue Mar 10, 2017 · 3 comments

Comments

@nbouwsma
Copy link

commented Mar 10, 2017

After upgrade to 7.8.1 we have observed that emails sent to newly created Portal Users are completely blank. Prior to version 7.8.1 the email welcomed them and provided login credentials to Joomla Customer Portal (1.1.1)

Issue

Email is sent but with no Subject or Body

Expected Behavior

Welcome email template should be invoked and contain the username and password to leverage the Customer Portal

Actual Behavior

Email is deliverd to the Portal User though completely blank. See https://www.suitecrm.com/forum/suitecrm-7-0-discussion/13070-aop-problem-templete-new-user-portal#44062

Possible Fix

Locate Template and invoke it to the email sent.

Steps to Reproduce

  1. On 7.8.1-7.8.2 Create New Portal User
  2. Receive Email that is blank.

Context

We now have to log into Joomla and set the authentication and provide to the Portal User manually

Your Environment

Suite CRM 7.8.1 Joomla Portal 3 using 1.1.1
Ubuntu 14.04

@chris001

This comment has been minimized.

Copy link
Contributor

commented Mar 10, 2017

Probably should also post issue to https://github.com/salesagility/SuiteCRM-Portal-Joomla/issues
Edit: never mind, the bug is happening when you create new portal user from inside the main app.

@nicodelon

This comment has been minimized.

Copy link

commented Mar 20, 2017

I confirm the description of this bug.
I have this problem : I setup and open AOP but when I created access portal user, the user is created in Joomla and all works fine but the email received by the user is totally empty.

Below, what the user expects to receive (for example) :
Hi Mr. Super COOL,

An account has been created for you at http://www.blabla-crm.fr/

You may login using this email address and the password BHS677SGU

Below, what the user receives (after portal account creation) :
subject : (empty)
body : (empty)

Below, what the user receives if we send him an email by ourselves via the Joomla creation account template :
Hi Mr. Super COOL,

An account has been created for you at $portal_address.

You may login using this email address and the password $joomla_pass

By the way, do you know if there is a way to retrieve the user account portal password ? The only way I could to retrieve it to consult log. For waiting a correction of this bug, we thaught to send an email manually with the passord but we did not success to retrieve it (it would be great if we could see it in a field on the contact).

So presently, for waiting, we decide to send an email including just the weblink portal and asking the user to create directly a new password with his own email on the portal page.

shogunpol pushed a commit to shogunpol/SuiteCRM that referenced this issue Mar 24, 2017
mattlorimer added a commit that referenced this issue Mar 24, 2017
@nbouwsma

This comment has been minimized.

Copy link
Author

commented Apr 11, 2017

Confirmed fixed. Thank you @shogunpol and @mattlorimer!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
7 participants
You can’t perform that action at this time.