Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

pep8 fixes

  • Loading branch information...
commit d12253bc9835e42e31c73b434a24c979b8a04a6e 1 parent 37f8a66
@kiorky kiorky authored
Showing with 19 additions and 20 deletions.
  1. +19 −20 salt/modules/lxc.py
View
39 salt/modules/lxc.py
@@ -47,26 +47,25 @@ def _ip_sort(ip):
def __virtual__():
if salt.utils.which('lxc-start'):
return True
- '''
- To speed up the whole thing, we decided to not use the
- subshell way and assume things are in place for lxc
- Discussion made by @kiorky and @thatch45
-
- lxc-version presence is not sufficient, in lxc1.0 alpha
- (precise backports), we have it and it is sufficient
- for the module to execute.
- elif salt.utils.which('lxc-version'):
- passed = False
- try:
- passed = subprocess.check_output(
- 'lxc-version').split(':')[1].strip() >= '1.0'
- except Exception:
- pass
- if not passed:
- log.warning('Support for lxc < 1.0 may be incomplete.')
- return 'lxc'
- return False
- '''
+ # To speed up the whole thing, we decided to not use the
+ # subshell way and assume things are in place for lxc
+ # Discussion made by @kiorky and @thatch45
+
+ # lxc-version presence is not sufficient, in lxc1.0 alpha
+ # (precise backports), we have it and it is sufficient
+ # for the module to execute.
+ # elif salt.utils.which('lxc-version'):
+ # passed = False
+ # try:
+ # passed = subprocess.check_output(
+ # 'lxc-version').split(':')[1].strip() >= '1.0'
+ # except Exception:
+ # pass
+ # if not passed:
+ # log.warning('Support for lxc < 1.0 may be incomplete.')
+ # return 'lxc'
+ # return False
+ #
return False
Please sign in to comment.
Something went wrong with that request. Please try again.