Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

tornado 5.1.1 is not co-installable with salt on python2.7 #50403

Open
prometheanfire opened this issue Nov 6, 2018 · 14 comments

Comments

Projects
None yet
4 participants
@prometheanfire
Copy link

commented Nov 6, 2018

Description of Issue/Question

Salt states that it works with tornado<6.0.0 in base.txt but the metadata it installs does not follow the python version specifier.

# grep tornado ~/.virtualenvs/salt-tornado/lib/python2.7/site-packages/salt-2018.3.3.dist-info/METADATA
Requires-Dist: tornado (<6.0,>=4.2.1)
Requires-Dist: tornado (<5.0,>=4.2.1)

When pip installing you get these lines relating to tornado.
Ignoring tornado: markers 'python_version >= "3.4"' don't match your environment
Requirement already satisfied: tornado<6.0,>=4.2.1; python_version < "3" in /home/mthode/.virtualenvs/salt-tornado/lib/python2.7/site-packages (from salt==2018.3.3) (5.1.1)
salt 2018.3.3 has requirement tornado<5.0,>=4.2.1, but you'll have tornado 5.1.1 which is incompatible.

Setup

no setup

Steps to Reproduce Issue

  1. Create new virtualenv
  2. pip install tornado===5.1.1
  3. pip install salt (or pip install .)

Versions Report

not installed, 2018.3.3 tested (from tag)

@prometheanfire

This comment has been minimized.

Copy link
Author

commented Nov 6, 2018

It seems to me you are doing a ton of custom stuff in setup.py that's shooting yourself in the foot. Just use setuptools/pkg_resources/etc for the requirements stuff. you can specify playforms, optional requirements (extras), etc.

@dwoz

This comment has been minimized.

Copy link
Contributor

commented Nov 7, 2018

@prometheanfire Thank you for reporting this. I have confirmed the issue.

@dwoz dwoz added this to the Approved milestone Nov 7, 2018

@dwoz dwoz added Packaging and removed Packaging labels Nov 7, 2018

@dwoz

This comment has been minimized.

Copy link
Contributor

commented Nov 7, 2018

@prometheanfire Can you provide us with the output of salt --versions-report and if you are unable to run that due to a broken install can you provide us the OS and Python Version?

@prometheanfire

This comment has been minimized.

Copy link
Author

commented Nov 7, 2018

keep in mind this is in a venv, but here it is.

Salt Version:
           Salt: 2018.3.0
 
Dependency Versions:
           cffi: Not Installed
       cherrypy: Not Installed
       dateutil: Not Installed
      docker-py: Not Installed
          gitdb: Not Installed
      gitpython: Not Installed
          ioflo: Not Installed
         Jinja2: 2.10
        libgit2: Not Installed
        libnacl: Not Installed
       M2Crypto: Not Installed
           Mako: Not Installed
   msgpack-pure: Not Installed
 msgpack-python: 0.5.6
   mysql-python: Not Installed
      pycparser: Not Installed
       pycrypto: 2.6.1
   pycryptodome: Not Installed
         pygit2: Not Installed
         Python: 2.7.15 (default, Sep 13 2018, 01:26:59)
   python-gnupg: Not Installed
         PyYAML: 3.13
          PyZMQ: 17.1.2
           RAET: Not Installed
          smmap: Not Installed
        timelib: Not Installed
        Tornado: 5.1.1
            ZMQ: 4.2.5
 
System Versions:
           dist: gentoo 2.4.1 
         locale: UTF-8
        machine: x86_64
        release: 4.18.16-gentoo
         system: Linux
        version: Gentoo Base System 2.4.1 
@prometheanfire

This comment has been minimized.

Copy link
Author

commented Nov 7, 2018

I noticed this bug in openstack co-installability tests for proposed updates. jaeger-client has this cap as well iirc.

http://logs.openstack.org/31/615731/1/check/requirements-tox-py27-check-uc/3712d13/job-output.txt.gz#_2018-11-06_06_35_48_249574

@dwoz dwoz self-assigned this Nov 26, 2018

@dwoz

This comment has been minimized.

Copy link
Contributor

commented Nov 26, 2018

Looks like we migrated to pipenv our setup.py isn't able to handle the requirements yet. This pipenv issue has a recipe for integrating with setup.py

@gtmanfred

This comment has been minimized.

Copy link
Contributor

commented Dec 13, 2018

I just want to state for the record, salt never migrated to pipenv. There is a Pipfile for people that wanted it, but all that was added was markers to the requirements.txt files.

@prometheanfire

This comment has been minimized.

Copy link
Author

commented Feb 27, 2019

@prometheanfire

This comment has been minimized.

Copy link
Author

commented Feb 27, 2019

@prometheanfire

This comment has been minimized.

Copy link
Author

commented Feb 27, 2019

I do wonder when this will be fixed

aeacd2b

@gtmanfred

This comment has been minimized.

Copy link
Contributor

commented Feb 27, 2019

@devurandom

This comment has been minimized.

Copy link

commented Mar 4, 2019

saltstack/salt-jenkins#995

That report was moved to #51883.

@devurandom

This comment has been minimized.

Copy link

commented Mar 6, 2019

@prometheanfire Is it possible to apply the patch you referenced in the Gentoo ebuild?

@prometheanfire

This comment has been minimized.

Copy link
Author

commented Mar 7, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.