Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

2019.2.1: pkgrepo.managed fails to use tornado4 curl_httpclient #54771

Open
crosscodr opened this issue Sep 26, 2019 · 2 comments

Comments

@crosscodr
Copy link

commented Sep 26, 2019

Description of Issue

pkgrepo.managed does not work if used with proxy (configured at salt-minion).
Error looks like this:

    Function: pkgrepo.managed
        Name: deb http://repo.saltstack.com/py3/debian/10/amd64/2019.2 buster main
      Result: False
     Comment: Failed to configure repo 'deb http://repo.saltstack.com/py3/debian/10/amd64/2019.2 buster main':
              name 'AsyncHTTPClient' is not defined
     Started: 15:29:27.435804
    Duration: 33.328 ms
     Changes:

Setup

State with pkgrepo.managed.

Steps to Reproduce Issue

Use pkgrepo.managed to manage a repo and provide key_url with https. Also configure proxy_host and proxy_port in minion config.

Versions Report

Master

salt --versions-report
Salt Version:
Salt: 2019.2.1

Dependency Versions:
cffi: Not Installed
cherrypy: Not Installed
dateutil: 2.6.1
docker-py: Not Installed
gitdb: 2.0.3
gitpython: 2.1.8
ioflo: Not Installed
Jinja2: 2.10
libgit2: Not Installed
libnacl: Not Installed
M2Crypto: Not Installed
Mako: Not Installed
msgpack-pure: Not Installed
msgpack-python: 0.5.6
mysql-python: Not Installed
pycparser: Not Installed
pycrypto: 2.6.1
pycryptodome: Not Installed
pygit2: Not Installed
Python: 3.6.8 (default, Aug 20 2019, 17:12:48)
python-gnupg: 0.4.1
PyYAML: 3.12
PyZMQ: 16.0.2
RAET: Not Installed
smmap: 2.0.3
timelib: Not Installed
Tornado: 4.5.3
ZMQ: 4.2.5

System Versions:
dist: Ubuntu 18.04 bionic
locale: UTF-8
machine: x86_64
release: 4.15.0-64-generic
system: Linux
version: Ubuntu 18.04 bionic

Minion

salt-minion --versions-report
Salt Version:
Salt: 2019.2.1

Dependency Versions:
cffi: Not Installed
cherrypy: Not Installed
dateutil: 2.7.3
docker-py: Not Installed
gitdb: Not Installed
gitpython: Not Installed
ioflo: Not Installed
Jinja2: 2.10
libgit2: Not Installed
libnacl: Not Installed
M2Crypto: Not Installed
Mako: Not Installed
msgpack-pure: Not Installed
msgpack-python: 0.5.6
mysql-python: Not Installed
pycparser: Not Installed
pycrypto: 2.6.1
pycryptodome: Not Installed
pygit2: Not Installed
Python: 3.7.3 (default, Apr 3 2019, 05:39:12)
python-gnupg: Not Installed
PyYAML: 3.13
PyZMQ: 17.1.2
RAET: Not Installed
smmap: Not Installed
timelib: Not Installed
Tornado: 4.5.3
ZMQ: 4.3.1

System Versions:
dist: debian 10.1
locale: UTF-8
machine: x86_64
release: 4.19.0-6-amd64
system: Linux
version: debian 10.1

@cmcmarrow cmcmarrow added this to the Approved milestone Sep 26, 2019
@cmcmarrow

This comment has been minimized.

Copy link
Contributor

commented Sep 26, 2019

I have been able to reproduce this problem. Thanks for telling us!

@dmurphy18

This comment has been minimized.

Copy link
Contributor

commented Sep 26, 2019

@cmcmarrow need to update quilt and patch in the spec file used https://github.com/saltstack/salt-pack-py3/blob/develop/file_roots/pkg/salt/2019_2/debian10/spec/salt_debian.tar.xz

COme chat when digging into it.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.