Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix pip state pip >=10.0 and <=18.0 #54807

Merged
merged 3 commits into from Sep 30, 2019
Merged
Changes from 1 commit
Commits
File filter...
Filter file types
Jump to…
Jump to file or symbol
Failed to load files and symbols.

Always

Just for now

Next

Fix import of pip modules

when using pip versions between 10.0 and 18.1, the import of the _internal modules in pip_state will fail.

Ref pip 10.0.0b1 release notes:
https://pip.pypa.io/en/stable/news/#b1-2018-03-31

This PR changes 18.1 to 10.0
  • Loading branch information
OrlandoArcapix authored and dwoz committed Sep 26, 2019
commit 42810a2ab55b48531cb45526bb7530ccdcef5e38
@@ -63,7 +63,7 @@
if HAS_PIP is True:
if salt.utils.versions.compare(ver1=pip.__version__,
oper='>=',
ver2='18.1'):
ver2='10.0'):
from pip._internal.exceptions import InstallationError # pylint: disable=E0611,E0401
elif salt.utils.versions.compare(ver1=pip.__version__,
oper='>=',
@@ -85,7 +85,7 @@ def _from_line(*args, **kwargs):
import pip
if salt.utils.versions.compare(ver1=pip.__version__,
oper='>=',
ver2='18.1'):
ver2='10.0'):
import pip._internal.req.constructors # pylint: disable=E0611,E0401
return pip._internal.req.constructors.install_req_from_line(*args, **kwargs)
elif salt.utils.versions.compare(ver1=pip.__version__,
ProTip! Use n and p to navigate between commits in a pull request.
You can’t perform that action at this time.