Increase minimum Perl version #16

Open
wants to merge 2 commits into
from

Conversation

Projects
None yet
1 participant
@paultcochrane
Contributor

paultcochrane commented Dec 28, 2016

This bumps the minimum Perl version up to 5.10. I realise that this is a controversial change and am opening this ticket essentially in order to discuss the point. It turned out that the CreateCAPI.pm file was already using a minimum Perl version of 5.13.2 due to its use of the /r regex modifier. I've worked around this issue so that the real minimum Perl version can be reduced again. However, since a benchmark requires 5.10 as well as one of the (albeit development) dependencies also requires 5.10 as a minimum version it seemed sensible to make the version bump. If you don't think this is the right thing to do, or if you think the issue could be solved more elegantly, please let me know and I'll try to update the PR as appropriate and resubmit.

paultcochrane added some commits Dec 28, 2016

Reduce Perl version requirement
The `r` regex modifier was added in Perl 5.13.2, hence to match the
minimum Perl version requirement, the older idiom for not modifying the
original string in a substitution needs to be used.  CreateCAPI.pm now
supports Perls 5.6+.
Increase minimum Perl version requirement to 5.10
This then matches the required version by the `Module::CAPIMaker` module
as well as the minimum version required in the `bm.pl` benchmark.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment