Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

version and gemspec for 3.3.0

  • Loading branch information...
commit 032ddf2f46970485ce30f44e8aca39b86265d919 1 parent 492f39d
@gnarg gnarg authored
Showing with 13 additions and 39 deletions.
  1. +1 −1  lib/new_relic/version.rb
  2. +12 −38 newrelic_rpm.gemspec
View
2  lib/new_relic/version.rb
@@ -4,7 +4,7 @@ module VERSION #:nodoc:
MAJOR = 3
MINOR = 3
TINY = 0
- BUILD = 'beta1' #'0' # Set to nil for a release, 'beta1', 'alpha', etc for prerelease builds
+ BUILD = nil # Set to nil for a release, 'beta1', 'alpha', etc for prerelease builds
STRING = [MAJOR, MINOR, TINY, BUILD].compact.join('.')
end
View
50 newrelic_rpm.gemspec
@@ -4,21 +4,15 @@
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{newrelic_rpm}
- s.version = "3.3.0.beta1"
+ s.name = "newrelic_rpm"
+ s.version = "3.3.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = [%q{Bill Kayser}, %q{Jon Guymon}, %q{Justin George}, %q{Darin Swanson}]
- s.date = %q{2011-11-01}
- s.description = %q{New Relic is a performance management system, developed by New Relic,
-Inc (http://www.newrelic.com). New Relic provides you with deep
-information about the performance of your web application as it runs
-in production. The New Relic Ruby Agent is dual-purposed as a either a
-Gem or plugin, hosted on
-http://github.com/newrelic/rpm/
-}
- s.email = %q{support@newrelic.com}
- s.executables = [%q{mongrel_rpm}, %q{newrelic}, %q{newrelic_cmd}]
+ s.authors = ["Bill Kayser", "Jon Guymon", "Justin George", "Darin Swanson"]
+ s.date = "2011-11-07"
+ s.description = "New Relic is a performance management system, developed by New Relic,\nInc (http://www.newrelic.com). New Relic provides you with deep\ninformation about the performance of your web application as it runs\nin production. The New Relic Ruby Agent is dual-purposed as a either a\nGem or plugin, hosted on\nhttp://github.com/newrelic/rpm/\n"
+ s.email = "support@newrelic.com"
+ s.executables = ["newrelic_cmd", "newrelic", "mongrel_rpm"]
s.extra_rdoc_files = [
"CHANGELOG",
"LICENSE",
@@ -286,32 +280,12 @@ http://github.com/newrelic/rpm/
"vendor/gems/metric_parser-0.1.0.pre1/lib/new_relic/metric_parser/web_service.rb",
"vendor/gems/metric_parser-0.1.0.pre1/lib/new_relic/metric_parser/web_transaction.rb"
]
- s.homepage = %q{http://www.github.com/newrelic/rpm}
- s.post_install_message = %q{
-PLEASE NOTE:
-
-Developer Mode is now a Rack middleware.
-
-Developer Mode is no longer available in Rails 2.1 and earlier.
-However, starting in version 2.12 you can use Developer Mode in any
-Rack based framework, in addition to Rails. To install developer mode
-in a non-Rails application, just add NewRelic::Rack::DeveloperMode to
-your middleware stack.
-
-If you are using JRuby, we recommend using at least version 1.4 or
-later because of issues with the implementation of the timeout library.
-
-Refer to the README.md file for more information.
-
-Please see http://github.com/newrelic/rpm/blob/master/CHANGELOG
-for a complete description of the features and enhancements available
-in version 3.3 of the Ruby Agent.
-
-}
s.rubygems_version = %q{1.3.6}
- s.rdoc_options = [%q{--line-numbers}, %q{--inline-source}, %q{--title}, %q{New Relic Ruby Agent}]
- s.require_paths = [%q{lib}]
- s.summary = %q{New Relic Ruby Agent}
+ s.homepage = "http://www.github.com/newrelic/rpm"
+ s.post_install_message = "\nPLEASE NOTE:\n\nDeveloper Mode is now a Rack middleware.\n\nDeveloper Mode is no longer available in Rails 2.1 and earlier.\nHowever, starting in version 2.12 you can use Developer Mode in any\nRack based framework, in addition to Rails. To install developer mode\nin a non-Rails application, just add NewRelic::Rack::DeveloperMode to\nyour middleware stack.\n\nIf you are using JRuby, we recommend using at least version 1.4 or \nlater because of issues with the implementation of the timeout library.\n\nRefer to the README.md file for more information.\n\nPlease see http://github.com/newrelic/rpm/blob/master/CHANGELOG\nfor a complete description of the features and enhancements available\nin version 3.3 of the Ruby Agent.\n \n"
+ s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "New Relic Ruby Agent"]
+ s.require_paths = ["lib"]
+ s.summary = "New Relic Ruby Agent"
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
Please sign in to comment.
Something went wrong with that request. Please try again.