Skip to content
The public speaking app that gives immediate feedback to help eliminate the use of filler words.
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
__tests__
android
ios
src
.babelrc
.buckconfig
.flowconfig
.gitattributes
.gitignore
.watchmanconfig
App.js
README.md
app.json
index.js
package-lock.json
package.json
yarn.lock

README.md

SpeakEz

The public speaking app that gives immediate feedback to help eliminate the use of filler words.

Getting Started

Environment setup

You will need at least Node, the React Native command line interface, a JDK, and Android Studio. Depending on your OS, you may need a few other tools as well.

The React Native documentation provides the best walkthrough on getting the proper environment setup to develop and run React Native apps. Follow the Getting Started section to install all the necessary tools for your OS and the platform you would like to run the application.

Be sure to follow the guide for Building Projects with Native Code. Do NOT follow the Quick Start instructions.

If you have any issues building the project, please open an issue including a stacktrackm and system info 💻

Building SpeakEz

# clone the repo
git clone git@github.com:samrose3/speakez.git

cd speakez

# install all project dependencies
npm install

# install the React Native CLI
npm install -g react-native-cli

# start it up
react-native run-ios

# or if using android
react-native run-android
You can’t perform that action at this time.