Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Code doesn't work in 1.8.7. Removed them from the travis file. Added …

…dependency to gemspec.
  • Loading branch information...
commit a2365b3ff02c70a41095b9a552f641853e589a93 1 parent fc1e877
Sam Rose authored
4 .travis.yml
View
@@ -1,9 +1,7 @@
rvm:
- - 1.8.7
+ - 1.9.1
- 1.9.2
- 1.9.3
- - jruby
- - rubinius
before_install:
- sudo apt-get update
2  Gemfile.lock
View
@@ -9,6 +9,7 @@ GEM
coderay (~> 1.0.5)
method_source (~> 0.7.1)
slop (>= 2.4.4, < 3)
+ rake (0.9.2.2)
rspec (2.10.0)
rspec-core (~> 2.10.0)
rspec-expectations (~> 2.10.0)
@@ -25,4 +26,5 @@ PLATFORMS
DEPENDENCIES
mkfifo
pry
+ rake
rspec
23 ruby-fifo.gemspec
View
@@ -1,15 +1,16 @@
require 'rubygems'
Gem::Specification.new {|s|
- s.name = 'ruby-fifo'
- s.version = '0.0.1'
- s.author = 'shura'
- s.email = 'shura1991@gmail.com'
- s.homepage = 'http://github.com/shurizzle/ruby-fifo'
- s.platform = Gem::Platform::RUBY
- s.summary = 'A cross-platform library to use named pipe'
- s.description = s.summary
- s.files = Dir['lib/*']
- s.require_path = 'lib'
- s.has_rdoc = true
+ s.name = 'ruby-fifo'
+ s.version = '0.0.1'
+ s.author = 'shura'
+ s.email = 'shura1991@gmail.com'
+ s.homepage = 'http://github.com/shurizzle/ruby-fifo'
+ s.platform = Gem::Platform::RUBY
+ s.required_ruby_version = '>= 1.9.1'
+ s.summary = 'A cross-platform library to use named pipe'
+ s.description = s.summary
+ s.files = Dir['lib/*']
+ s.require_path = 'lib'
+ s.has_rdoc = true
}
0  spec/data/includeme
View
No changes.
Please sign in to comment.
Something went wrong with that request. Please try again.