Permalink
Browse files

Remove jeweler

  • Loading branch information...
1 parent 217c2c4 commit eac8926172cbb94e43ad8b68188603fd3890aa85 Jon Larkowski and Les Hill committed with leshill Mar 9, 2011
Showing with 33 additions and 145 deletions.
  1. +1 −0 .gitignore
  2. +0 −25 Rakefile
  3. +0 −1 VERSION
  4. +3 −0 lib/specjour/version.rb
  5. +29 −119 specjour.gemspec
View
@@ -17,6 +17,7 @@ tmtags
coverage
rdoc
pkg
+*.gem
## PROJECT::SPECIFIC
.specjour
View
@@ -1,29 +1,6 @@
require 'rubygems'
require 'rake'
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "specjour"
- gem.summary = %Q{Distribute your spec suite amongst your LAN via Bonjour.}
- gem.description = %Q{Distribute your spec suite amongst your LAN via Bonjour.}
- gem.email = "sandro.turriate@gmail.com"
- gem.homepage = "http://github.com/sandro/specjour"
- gem.authors = ["Sandro Turriate"]
- gem.add_dependency "dnssd", "1.3.4"
- gem.add_dependency "thor", ">=0.14.0"
- gem.add_development_dependency "rspec", "1.3.0"
- gem.add_development_dependency "rr", ">=0.10.11"
- gem.add_development_dependency "cucumber", ">=0.9.0"
- gem.add_development_dependency "yard", ">=0.5.3"
- gem.add_development_dependency "jeweler", ">=1.4.0"
- # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
-end
-
require 'spec/rake/spectask'
Spec::Rake::SpecTask.new(:spec) do |spec|
spec.libs << 'lib' << 'spec'
@@ -36,8 +13,6 @@ Spec::Rake::SpecTask.new(:rcov) do |spec|
spec.rcov = true
end
-task :spec => :check_dependencies
-
task :default => :spec
begin
View
@@ -1 +0,0 @@
-0.3.1
View
@@ -0,0 +1,3 @@
+module Specjour
+ VERSION = '0.3.1'
@sandro

sandro Mar 9, 2011

Owner

VERSION is already defined in lib/specjour.rb. I never liked having a separate version file myself.

@l4rk

l4rk Mar 9, 2011

Collaborator

Roger that, we're putting it back.

+end
View
@@ -1,125 +1,35 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
-# -*- encoding: utf-8 -*-
+lib = File.expand_path('../lib/', __FILE__)
+$:.unshift lib unless $:.include?(lib)
+
+require 'specjour/version'
Gem::Specification.new do |s|
- s.name = %q{specjour}
- s.version = "0.3.1"
+ s.required_rubygems_version = '>= 1.3.6'
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Sandro Turriate"]
- s.date = %q{2010-10-16}
- s.default_executable = %q{specjour}
- s.description = %q{Distribute your spec suite amongst your LAN via Bonjour.}
- s.email = %q{sandro.turriate@gmail.com}
- s.executables = ["specjour"]
- s.extra_rdoc_files = [
- "README.markdown"
- ]
- s.files = [
- ".dev",
- ".document",
- ".gitignore",
- ".rvmrc",
- "Gemfile",
- "History.markdown",
- "MIT_LICENSE",
- "README.markdown",
- "Rakefile",
- "VERSION",
- "bin/specjour",
- "lib/specjour.rb",
- "lib/specjour/cli.rb",
- "lib/specjour/configuration.rb",
- "lib/specjour/connection.rb",
- "lib/specjour/cpu.rb",
- "lib/specjour/cucumber.rb",
- "lib/specjour/cucumber/distributed_formatter.rb",
- "lib/specjour/cucumber/final_report.rb",
- "lib/specjour/cucumber/main_ext.rb",
- "lib/specjour/cucumber/preloader.rb",
- "lib/specjour/cucumber/runner.rb",
- "lib/specjour/db_scrub.rb",
- "lib/specjour/dispatcher.rb",
- "lib/specjour/manager.rb",
- "lib/specjour/printer.rb",
- "lib/specjour/protocol.rb",
- "lib/specjour/quiet_fork.rb",
- "lib/specjour/rspec.rb",
- "lib/specjour/rspec/distributed_formatter.rb",
- "lib/specjour/rspec/final_report.rb",
- "lib/specjour/rspec/marshalable_exception.rb",
- "lib/specjour/rspec/marshalable_rspec_failure.rb",
- "lib/specjour/rspec/preloader.rb",
- "lib/specjour/rspec/runner.rb",
- "lib/specjour/rspec2/distributed_formatter.rb",
- "lib/specjour/rspec2/final_report.rb",
- "lib/specjour/rspec2/runner.rb",
- "lib/specjour/rspec2/shared_example_group_ext.rb",
- "lib/specjour/rsync_daemon.rb",
- "lib/specjour/socket_helper.rb",
- "lib/specjour/worker.rb",
- "sample/features/fail.feature",
- "sample/features/pass.feature",
- "sample/features/step_definitions/sample_steps.rb",
- "sample/features/undefined.feature",
- "spec/spec.opts",
- "spec/spec_helper.rb",
- "spec/specjour/cli_spec.rb",
- "spec/specjour/configuration_spec.rb",
- "spec/specjour/cpu_spec.rb",
- "spec/specjour/manager_spec.rb",
- "spec/specjour/printer_spec.rb",
- "spec/specjour/rsync_daemon_spec.rb",
- "spec/specjour_spec.rb",
- "specjour.gemspec"
- ]
- s.homepage = %q{http://github.com/sandro/specjour}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Distribute your spec suite amongst your LAN via Bonjour.}
- s.test_files = [
- "spec/spec_helper.rb",
- "spec/specjour/cli_spec.rb",
- "spec/specjour/configuration_spec.rb",
- "spec/specjour/cpu_spec.rb",
- "spec/specjour/manager_spec.rb",
- "spec/specjour/printer_spec.rb",
- "spec/specjour/rsync_daemon_spec.rb",
- "spec/specjour_spec.rb"
- ]
+ s.version = Specjour::VERSION
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.name = 'specjour'
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<dnssd>, ["= 1.3.4"])
- s.add_runtime_dependency(%q<thor>, [">= 0.14.0"])
- s.add_development_dependency(%q<rspec>, ["= 1.3.0"])
- s.add_development_dependency(%q<rr>, [">= 0.10.11"])
- s.add_development_dependency(%q<cucumber>, [">= 0.9.0"])
- s.add_development_dependency(%q<yard>, [">= 0.5.3"])
- s.add_development_dependency(%q<jeweler>, [">= 1.4.0"])
- else
- s.add_dependency(%q<dnssd>, ["= 1.3.4"])
- s.add_dependency(%q<thor>, [">= 0.14.0"])
- s.add_dependency(%q<rspec>, ["= 1.3.0"])
- s.add_dependency(%q<rr>, [">= 0.10.11"])
- s.add_dependency(%q<cucumber>, [">= 0.9.0"])
- s.add_dependency(%q<yard>, [">= 0.5.3"])
- s.add_dependency(%q<jeweler>, [">= 1.4.0"])
- end
- else
- s.add_dependency(%q<dnssd>, ["= 1.3.4"])
- s.add_dependency(%q<thor>, [">= 0.14.0"])
- s.add_dependency(%q<rspec>, ["= 1.3.0"])
- s.add_dependency(%q<rr>, [">= 0.10.11"])
- s.add_dependency(%q<cucumber>, [">= 0.9.0"])
- s.add_dependency(%q<yard>, [">= 0.5.3"])
- s.add_dependency(%q<jeweler>, [">= 1.4.0"])
- end
-end
+ s.authors = ['Sandro Turriate']
+ s.email = 'sandro.turriate@gmail.com'
+ s.homepage = 'https://github.com/sandro/specjour'
+ s.summary = 'Distribute your spec suite amongst your LAN via Bonjour.'
+ s.description = <<-EOD
+ Specjour splits your RSpec suite across multiple machines, and multiple
+ cores per machine, to run super-parallel-fast! Also works with Cucumber.
+ EOD
+
+ s.default_executable = 'specjour'
+ s.executables = ['specjour']
+ s.require_path = 'lib'
+
+ s.files = Dir.glob('lib/**/*') + %w(MIT_LICENSE README.markdown History.markdown Rakefile bin/specjour)
+
+ s.add_runtime_dependency('dnssd', ['= 1.3.4'])
+ s.add_runtime_dependency('thor', ['>= 0.14.0'])
+ s.add_development_dependency('rspec', ['= 1.3.0'])
+ s.add_development_dependency('rr', ['>= 0.10.11'])
+ s.add_development_dependency('cucumber', ['>= 0.9.0'])
+ s.add_development_dependency('yard', ['>= 0.5.3'])
+end

0 comments on commit eac8926

Please sign in to comment.