Specjour doesn't work with latest cucumber version #39

Open
paulelliott opened this Issue Jun 6, 2012 · 2 comments

Projects

None yet

3 participants

@paulelliott

I get this error when I try to run 0.5.5 with cucumber-rails 1.3.0

/Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/cucumber/distributed_formatter.rb:2:in `<module:Cucumber>': uninitialized constant Term (NameError)
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/cucumber/distributed_formatter.rb:1:in `<top (required)>'
    from /Users/dev/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /Users/dev/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/cucumber.rb:6:in `<module:Cucumber>'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/cucumber.rb:2:in `<module:Specjour>'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/cucumber.rb:1:in `<top (required)>'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/loader.rb:85:in `load_app'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/loader.rb:22:in `start'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/cli.rb:57:in `load'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/thor-0.14.6/lib/thor/task.rb:22:in `run'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/thor-0.14.6/lib/thor/invocation.rb:118:in `invoke_task'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/thor-0.14.6/lib/thor.rb:263:in `dispatch'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/thor-0.14.6/lib/thor/base.rb:389:in `start'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/lib/specjour/cli.rb:24:in `start'
    from /Users/dev/.rvm/gems/ruby-1.9.3-p194@search_discovery/gems/specjour-0.5.5/bin/specjour:5:in `<main>'
@sandro
Owner

Thanks for letting me know. Will look into it.

@pierreozoux
Collaborator

We run with 1.3.1 without any issues, you can close.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment