"Back" button from buffer-list returns to login screen, even when connected #51

Closed
aziraphale opened this Issue Apr 7, 2012 · 1 comment

Comments

Projects
None yet
2 participants
Contributor

aziraphale commented Apr 7, 2012

If, on the buffer list activity, you press the phone's "back" button, you're returned to the login screen, even though you're already connected. Similarly, if you launch the app from the launcher or homescreen (instead of the notification bar) when it's already connected, you're presented with just the login screen instead of the buffer list.

I fixed this in my fork, but I think I messed up somewhere along the line, so any pull request I try to make seems to have github asking you to pull in 36 of my commits, which is just crazy (some are probably useful features, but I'm not satisfied that many are stable enough to be pulled into the main project just yet...).

Anyway, my fix is here: aziraphale/QuasselDroid@9dd257e

Very simple fix to a very annoying bug :)

Collaborator

kenborge commented Jun 23, 2012

This is fixed in master now, fixed it by introducing a splash screen when starting the app if all activities have been killed. Figured that would look better then the login screen flashing for a second before it sends you to the buffer activity. Also made backing from the buffer view if connected actually back you out of the application as bumping you to login makes little sense if you are already connected.

@kenborge kenborge closed this Jun 25, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment