@sassbot sassbot released this Oct 11, 2018 · 6 commits to master since this release

Assets 8

To install Dart Sass 1.14.2, download one of the packages above and add it to your PATH, or see the Sass website for full installation instructions.

Changes

  • Fix a bug where loading the same stylesheet from two different import paths could cause its imports to fail to resolve.

  • Properly escape U+001F INFORMATION SEPARATOR ONE in unquoted strings.

Command-Line Interface

  • Don't crash when using @debug in a stylesheet passed on standard input.

Dart API

  • AsyncImporter.canonicalize() and Importer.canonicalize() must now return absolute URLs. Relative URLs are still supported, but are deprecated and will be removed in a future release.

See the full changelog for changes in earlier releases.