Skip to content

@sassbot sassbot released this Apr 8, 2019 · 5 commits to master since this release

To install Dart Sass 1.18.0, download one of the packages above and add it to your PATH, or see the Sass website for full installation instructions.

Changes

  • Avoid recursively listing directories when finding the canonical name of a file on case-insensitive filesystems.

  • Fix importing files relative to package:-imported files.

  • Don't claim that "package:" URLs aren't supported when they actually are.

Command-Line Interface

  • Add a --no-charset flag. If this flag is set, Sass will never emit a @charset declaration or a byte-order mark, even if the CSS file contains non-ASCII characters.

Dart API

  • Add a charset option to compile(), compileString(), compileAsync() and compileStringAsync(). If this option is set to false, Sass will never emit a @charset declaration or a byte-order mark, even if the CSS file contains non-ASCII characters.

  • Explicitly require that importers' canonicalize() methods be able to take paths relative to their outputs as valid inputs. This isn't considered a breaking change because the importer infrastructure already required this in practice.

See the full changelog for changes in earlier releases.

Assets 8
You can’t perform that action at this time.