Skip to content

@sassbot sassbot released this Sep 11, 2019

To install Dart Sass 1.22.12, download one of the packages above and add it to your PATH, or see the Sass website for full installation instructions.

Changes

  • Potentially breaking bug fix: character sequences consisting of two or more hyphens followed by a number (such as --123), or two or more hyphens on their own (such as --), are now parsed as identifiers in accordance with the CSS spec.

    The sequence -- was previously parsed as multiple applications of the - operator. Since this is unlikely to be used intentionally in practice, we consider this bug fix safe.

Command-Line Interface

  • Fix a bug where changes in .css files would be ignored in --watch mode.

JavaScript API

  • Allow underscore-separated custom functions to be defined.

  • Improve the performance of Node.js compilation involving many @imports.

See the full changelog for changes in earlier releases.

Assets 8
You can’t perform that action at this time.