New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can't Install 4.5.3: npm ERR! 404 Not Found ansi-styles-2.2.0.tgz #2084

Closed
ant-fx opened this Issue Aug 31, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@ant-fx

ant-fx commented Aug 31, 2017

  • NPM version (npm -v): 5.3.0
  • Node version (node -v): v6.11.1
  • Node Process (node -p process.versions):
    { http_parser: '2.7.0',
    node: '6.11.1',
    v8: '5.1.281.103',
    uv: '1.11.0',
    zlib: '1.2.11',
    ares: '1.10.1-DEV',
    icu: '58.2',
    modules: '48',
    openssl: '1.0.2k' }
  • Node Platform (node -p process.platform): darwin
  • Node architecture (node -p process.arch): x64
  • node-sass version (node -p "require('node-sass').info"): Wont install
  • npm node-sass versions (npm ls node-sass): UNMET DEPENDENCY node-sass@4.5.3

When install the module npm install node-sass@4.5.3 I get the following:

npm ERR! code E404
npm ERR! 404 Not Found: ansi-styles@http://registry.npmjs.org/ansi-styles/-/ansi-styles-2.2.0.tgz

It seems that node-sass@4.5.3 uses chalk@^1.1.1 which uses ansi-styles-2.2.0 which is no longer available on npmjs.

I suppose the solution should be to upgrade chalk to the latest version 2.1.0?

@xzyfer

This comment has been minimized.

Show comment
Hide comment
@xzyfer

xzyfer Aug 31, 2017

Contributor

This seems like a transient issue. I was able to successfully install node-sass.

└─┬ node-sass@4.5.3
  ├── async-foreach@0.1.3
  ├─┬ chalk@1.1.3

Remove your node_modules and try again.

Contributor

xzyfer commented Aug 31, 2017

This seems like a transient issue. I was able to successfully install node-sass.

└─┬ node-sass@4.5.3
  ├── async-foreach@0.1.3
  ├─┬ chalk@1.1.3

Remove your node_modules and try again.

@xzyfer xzyfer closed this Aug 31, 2017

@Harish2887

This comment has been minimized.

Show comment
Hide comment
@Harish2887

Harish2887 Oct 14, 2017

tried but still not working

Harish2887 commented Oct 14, 2017

tried but still not working

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment