Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 36 lines (32 sloc) 1.605 kB
ec2e0e6 @nex3 Add requires to the gemspec necessary to get it to run with 'gem build.'
nex3 authored
1 require 'rubygems'
2
80c3b87 @nex3 Excise Haml from within files.
nex3 authored
3 # Note that Sass's gem-compilation process requires access to the filesystem.
27891c5 @nex3 Add some documentation about haml-edge.
nex3 authored
4 # This means that it cannot be automatically run by e.g. GitHub's gem system.
5 # However, a build server automatically packages the master branch
f188f4b @nex3 Merge branch 'shared' into sass-only
nex3 authored
6 # every time it's pushed to; this is made available as a prerelease gem.
80c3b87 @nex3 Excise Haml from within files.
nex3 authored
7 SASS_GEMSPEC = Gem::Specification.new do |spec|
8 spec.rubyforge_project = 'sass'
f188f4b @nex3 Merge branch 'shared' into sass-only
nex3 authored
9 spec.name = 'sass'
80c3b87 @nex3 Excise Haml from within files.
nex3 authored
10 spec.summary = "A powerful but elegant CSS compiler that makes CSS fun again."
e167efa @nex3 Scope all file accesses in the Rakefile so it'll work regardless of cwd.
nex3 authored
11 spec.version = File.read(File.dirname(__FILE__) + '/VERSION').strip
6f192ce @nex3 Use my new name everywhere.
nex3 authored
12 spec.authors = ['Natalie Weizenbaum', 'Chris Eppstein', 'Hampton Catlin']
80c3b87 @nex3 Excise Haml from within files.
nex3 authored
13 spec.email = 'sass-lang@googlegroups.com'
6a60485 @nex3 Move the Haml gemspec into its own file.
nex3 authored
14 spec.description = <<-END
7471852 @nex3 Get rid of references to "CSS3".
nex3 authored
15 Sass makes CSS fun again. Sass is an extension of CSS, adding
80c3b87 @nex3 Excise Haml from within files.
nex3 authored
16 nested rules, variables, mixins, selector inheritance, and more.
17 It's translated to well-formatted, standard CSS using the
18 command line tool or a web-framework plugin.
6a60485 @nex3 Move the Haml gemspec into its own file.
nex3 authored
19 END
20
2bf1e1a @ericmason Require Ruby >= 1.8.7
ericmason authored
21 spec.required_ruby_version = '>= 1.8.7'
14c4a88 @nex3 Upgrade to YARD 0.5.3.
nex3 authored
22 spec.add_development_dependency 'yard', '>= 0.5.3'
242aee3 @nex3 Add developer dependencies to the gem for building the documentation.
nex3 authored
23 spec.add_development_dependency 'maruku', '>= 0.5.9'
16f166d @movitto Update to minitest 5
movitto authored
24 spec.add_development_dependency 'minitest', '>= 5'
242aee3 @nex3 Add developer dependencies to the gem for building the documentation.
nex3 authored
25
4cdbaf3 @gmccreight Removed require rake by switching to Dir.[].
gmccreight authored
26 readmes = Dir['*'].reject{ |x| x =~ /(^|[^.a-z])[a-z]+/ || x == "TODO" }
9cc7a97 @chriseppstein Actually ship the scss executable that we have had for a while now.
chriseppstein authored
27 spec.executables = ['sass', 'sass-convert', 'scss']
4cdbaf3 @gmccreight Removed require rake by switching to Dir.[].
gmccreight authored
28 spec.files = Dir['rails/init.rb', 'lib/**/*', 'vendor/**/*',
9c60968 @nex3 [Sass] Include FSSM in the gemspec.
nex3 authored
29 'bin/*', 'test/**/*', 'extra/**/*', 'Rakefile', 'init.rb',
4cdbaf3 @gmccreight Removed require rake by switching to Dir.[].
gmccreight authored
30 '.yardopts'] + readmes
80c3b87 @nex3 Excise Haml from within files.
nex3 authored
31 spec.homepage = 'http://sass-lang.com/'
5af9dbf @nex3 Set has_rdoc = false in the gemfile.
nex3 authored
32 spec.has_rdoc = false
4cdbaf3 @gmccreight Removed require rake by switching to Dir.[].
gmccreight authored
33 spec.test_files = Dir['test/**/*_test.rb']
8dcb6d8 @jordimassaguerpla add license information to gemspec
jordimassaguerpla authored
34 spec.license = "MIT"
6a60485 @nex3 Move the Haml gemspec into its own file.
nex3 authored
35 end
Something went wrong with that request. Please try again.