Permalink
Browse files

Allow any listen version before 3.0.0.

  • Loading branch information...
1 parent e37a516 commit 3103b4d98eeea287ac09c3226b46c3aaf203a009 @nex3 nex3 committed Feb 28, 2014
Showing with 3 additions and 3 deletions.
  1. +1 −1 Gemfile
  2. +2 −2 ext/mkrf_conf.rb
View
@@ -14,7 +14,7 @@ if RUBY_VERSION =~ /^1\.8/
elsif RUBY_VERSION =~ /^1\.9\.[012]$/
gem 'listen', '>= 1.1.0', '< 2.0.0'
else
- gem 'listen', '>= 1.1.0', '< 2.5.0'
+ gem 'listen', '>= 1.1.0', '< 3.0.0'
end
gem 'rubyforge', :group => :development
View
@@ -14,8 +14,8 @@
Gem::Command.build_args = ARGV
inst = Gem::DependencyInstaller.new
if Sass::Util.version_geq(RUBY_VERSION, "1.9.3")
- puts "Installing listen >= 1.1.0, < 2.5"
- inst.install "listen", Gem::Requirement.new(">= 1.1.0", "< 2.5")
+ puts "Installing listen >= 1.1.0, < 3.0.0"
+ inst.install "listen", Gem::Requirement.new(">= 1.1.0", "< 3.0.0")
else
puts "Installing listen ~> 1.1.0"
inst.install "listen", "~> 1.1.0"

0 comments on commit 3103b4d

Please sign in to comment.