Sass installation failure #1130

Closed
ebowers opened this Issue Feb 23, 2014 · 9 comments

Comments

Projects
None yet
5 participants
@ebowers

ebowers commented Feb 23, 2014

I started this conversation at
Team-Sass/generator-style-prototype#47
and was recommended to head over here. Any ideas?


Sorry if this is a silly question, I'm still learning to use the terminal. But when I run the yeoman generator installer, I am getting this failure with sass. Not sure what is going on, if you have a free moment I would really appreciate any help at all.

Installing sass (3.3.0.rc.4)
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

....and then down at the bottom ....

An error occurred while installing sass (3.3.0.rc.4), and Bundler cannot
continue.
Make sure that gem install sass -v '3.3.0.rc.4' succeeds before bundling.

Exited with code: 5.
Warning: Task "exec:bundle:." failed. Use --force to continue.

@lolmaus

This comment has been minimized.

Show comment Hide comment
@lolmaus

lolmaus Feb 23, 2014

Are you on Windows?

lolmaus commented Feb 23, 2014

Are you on Windows?

@ebowers

This comment has been minimized.

Show comment Hide comment
@ebowers

ebowers Feb 23, 2014

Mac 10.9.1

ebowers commented Feb 23, 2014

Mac 10.9.1

@nex3

This comment has been minimized.

Show comment Hide comment
@nex3

nex3 Feb 24, 2014

Contributor

Please post the entire installation log.

Contributor

nex3 commented Feb 24, 2014

Please post the entire installation log.

@nex3 nex3 added Bug labels Feb 24, 2014

@ebowers

This comment has been minimized.

Show comment Hide comment
@ebowers

ebowers Feb 24, 2014

After installing the Style Prototype package through yeoman, I try running a grunt server command and I get this error with SASS.

➜  testproject  grunt server
Running "server" task

Running "bundler" task

Running "exec:bundle:." (exec) task
Fetching gem metadata from https://rubygems.org/..............
Fetching gem metadata from https://rubygems.org/..
Resolving dependencies...
Installing chunky_png (1.3.0) 
Installing multi_json (1.8.4) 
Installing sass (3.3.0.rc.5) 
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/bin/ruby mkrf_conf.rb 
Ensuring you have the right version of listen installed.
Installing listen >= 1.1.0, < 2.5
Building native extensions.  This could take a while...

rake RUBYARCHDIR=/Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5 RUBYLIBDIR=/Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5
/Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:298:in `to_specs': Could not find 'rake' (>= 0) among 8 total gem(s) (Gem::LoadError)
    from /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:309:in `to_spec'
    from /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_gem.rb:53:in `gem'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194@global/bin/rake:18:in `<main>'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

rake failed, exit code 1

Gem files will remain installed in /Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/gems/sass-3.3.0.rc.5 for inspection.
Results logged to /Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5/gem_make.out
An error occurred while installing sass (3.3.0.rc.5), and Bundler cannot
continue.
Make sure that `gem install sass -v '3.3.0.rc.5'` succeeds before bundling.
>> Exited with code: 5.
Warning: Task "exec:bundle:." failed. Use --force to continue.

Aborted due to warnings.
➜  testproject 

ebowers commented Feb 24, 2014

After installing the Style Prototype package through yeoman, I try running a grunt server command and I get this error with SASS.

➜  testproject  grunt server
Running "server" task

Running "bundler" task

Running "exec:bundle:." (exec) task
Fetching gem metadata from https://rubygems.org/..............
Fetching gem metadata from https://rubygems.org/..
Resolving dependencies...
Installing chunky_png (1.3.0) 
Installing multi_json (1.8.4) 
Installing sass (3.3.0.rc.5) 
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/bin/ruby mkrf_conf.rb 
Ensuring you have the right version of listen installed.
Installing listen >= 1.1.0, < 2.5
Building native extensions.  This could take a while...

rake RUBYARCHDIR=/Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5 RUBYLIBDIR=/Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5
/Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:298:in `to_specs': Could not find 'rake' (>= 0) among 8 total gem(s) (Gem::LoadError)
    from /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:309:in `to_spec'
    from /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_gem.rb:53:in `gem'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194@global/bin/rake:18:in `<main>'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

rake failed, exit code 1

Gem files will remain installed in /Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/gems/sass-3.3.0.rc.5 for inspection.
Results logged to /Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5/gem_make.out
An error occurred while installing sass (3.3.0.rc.5), and Bundler cannot
continue.
Make sure that `gem install sass -v '3.3.0.rc.5'` succeeds before bundling.
>> Exited with code: 5.
Warning: Task "exec:bundle:." failed. Use --force to continue.

Aborted due to warnings.
➜  testproject 
@chriseppstein

This comment has been minimized.

Show comment Hide comment
@chriseppstein

chriseppstein Feb 24, 2014

Member

Results logged to /Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5/gem_make.out

Can you include the contents of that file too?

Member

chriseppstein commented Feb 24, 2014

Results logged to /Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5/gem_make.out

Can you include the contents of that file too?

@ebowers

This comment has been minimized.

Show comment Hide comment
@ebowers

ebowers Feb 24, 2014

/Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/bin/ruby mkrf_conf.rb 
Ensuring you have the right version of listen installed.
Installing listen >= 1.1.0, < 2.5
Building native extensions.  This could take a while...

rake RUBYARCHDIR=/Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5 RUBYLIBDIR=/Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5
/Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:298:in `to_specs': Could not find 'rake' (>= 0) among 8 total gem(s) (Gem::LoadError)
    from /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:309:in `to_spec'
    from /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_gem.rb:53:in `gem'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194@global/bin/rake:18:in `<main>'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

rake failed, exit code 1

ebowers commented Feb 24, 2014

/Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/bin/ruby mkrf_conf.rb 
Ensuring you have the right version of listen installed.
Installing listen >= 1.1.0, < 2.5
Building native extensions.  This could take a while...

rake RUBYARCHDIR=/Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5 RUBYLIBDIR=/Applications/MAMP/htdocs/test-prototype/testproject/.vendor/ruby/1.9.1/extensions/x86_64-darwin-12/1.9.1/sass-3.3.0.rc.5
/Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:298:in `to_specs': Could not find 'rake' (>= 0) among 8 total gem(s) (Gem::LoadError)
    from /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:309:in `to_spec'
    from /Users/ebgd85/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/core_ext/kernel_gem.rb:53:in `gem'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194@global/bin/rake:18:in `<main>'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'
    from /Users/ebgd85/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

rake failed, exit code 1
@nex3

This comment has been minimized.

Show comment Hide comment
@nex3

nex3 Feb 24, 2014

Contributor

It looks like we just need to add a dependency on Rake.

Contributor

nex3 commented Feb 24, 2014

It looks like we just need to add a dependency on Rake.

@nex3 nex3 removed the Awaiting Response label Feb 24, 2014

@nex3 nex3 added this to the 3.3 milestone Feb 24, 2014

@aladine

This comment has been minimized.

Show comment Hide comment
@aladine

aladine Feb 28, 2014

If you are using MacOS, most likely Xcode tool is not update yet.
Try this link: http://stackoverflow.com/questions/19580685/installing-rails-on-mavericks

aladine commented Feb 28, 2014

If you are using MacOS, most likely Xcode tool is not update yet.
Try this link: http://stackoverflow.com/questions/19580685/installing-rails-on-mavericks

@ebowers

This comment has been minimized.

Show comment Hide comment
@ebowers

ebowers Feb 28, 2014

@aladine updated xcode and I'm still getting the same error.

ebowers commented Feb 28, 2014

@aladine updated xcode and I'm still getting the same error.

nex3 added a commit that referenced this issue Feb 28, 2014

Add a dependency on Rake.
This is necessary for mkrf_conf to work.

Closes #1130

@nex3 nex3 closed this Feb 28, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment