Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

require 'sass' fails under MacRuby with U_REGEX_BAD_ESCAPE_SEQUENCE #431

Closed
willglynn opened this Issue Jun 26, 2012 · 0 comments

Comments

Projects
None yet
2 participants
Contributor

willglynn commented Jun 26, 2012

To reproduce:

$ cat > test.rb
require 'rubygems'
require 'sass'
^D
$ macruby test.rb
/path/to/gems/sass-3.1.19/lib/sass/scss/rx.rb:52:in `block': regexp `[\u{80}-\u{D7FF}\u{E000}-\u{FFFD}\u{10000}-\u{10FFFF}]' compilation error: U_REGEX_BAD_ESCAPE_SEQUENCE (RegexpError)

I'm not sure if this would be considered a MacRuby issue or a sass issue, but I thought I'd raise it here anyway. I also found another post on this topic by someone who knows more about MacRuby, offering a possible workaround:
http://permalink.gmane.org/gmane.comp.lang.ruby.macintosh.devel/6833

@nex3 nex3 closed this in a92a6ab Jun 30, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment