Skip to content
This repository
Newer
Older
100644 34 lines (30 sloc) 1.036 kb
2abb733f »
2010-05-07 setup.py
1 # -*- coding: utf-8 -*-
4539d8c9 »
2010-07-27 clarify the situation with OrderedDict
2 import sys
668ea116 »
2010-05-07 fixes
3 try:
4 from setuptools import setup
5 except ImportError:
6 from distutils.core import setup
2abb733f »
2010-05-07 setup.py
7
668ea116 »
2010-05-07 fixes
8 from monocle import VERSION
9
4539d8c9 »
2010-07-27 clarify the situation with OrderedDict
10 install_requires = []
11 if sys.version_info < (2, 7):
12 install_requires.append('ordereddict')
13
668ea116 »
2010-05-07 fixes
14 setup(name="monocle",
15 version=VERSION,
16 description="An async programming framework with a blocking look-alike syntax",
17 author="Greg Hazel and Steven Hazel",
18 author_email="sah@awesame.org",
19 maintainer="Steven Hazel",
20 maintainer_email="sah@awesame.org",
21 url="http://github.com/saucelabs/monocle",
d580d96b »
2010-06-10 fixing pypi package, version bump
22 packages=['monocle',
23 'monocle.stack',
24 'monocle.stack.network',
25 'monocle.twisted_stack',
26 'monocle.twisted_stack.network',
27 'monocle.tornado_stack',
28 'monocle.tornado_stack.network',
29 'monocle.asyncore_stack',
30 'monocle.asyncore_stack.network'],
4539d8c9 »
2010-07-27 clarify the situation with OrderedDict
31 install_requires=install_requires,
668ea116 »
2010-05-07 fixes
32 license='MIT'
33 )
Something went wrong with that request. Please try again.