Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Updating Fern on Kali Linux fails #60

Open
GoogleCodeExporter opened this Issue Mar 23, 2015 · 22 comments

Comments

Projects
None yet
1 participant
What steps will reproduce the problem?
1. Install Kali Linux 1
2. Load Fern and update from app window
3. After install is done updated Fern will not load.

What is the expected output? Fern loading What do you see instead? Nothing


What version of the product are you using? LAtest On what operating system? 
Kali Linux 1


Please provide any additional information below.


Original issue reported on code.google.com by pascaldo...@gmail.com on 21 Mar 2013 at 3:09

Please run the program in terminal, and report back any error that is 
generated..

Thanks :)

Original comment by savioboy...@gmail.com on 23 Mar 2013 at 10:57

root@CPE902b34d5fa55-CM3c754a3472b6:~# fern-wifi-cracker
/usr/bin/fern-wifi-cracker: line 3: /usr/share/fern-wifi-cracker/execute.py: 
Permission denied

Original comment by pascaldo...@gmail.com on 27 Mar 2013 at 7:55

chmod +x /usr/share/fern-wifi-cracker/execute.py

Original comment by skvat...@gmail.com on 28 Mar 2013 at 7:38

yeah I did chmod 777 

worked fine. But some fix has to be done with the installer. Also there are no 
updates but clicking on the download button downloads and installs anyways. The 
current version. Also all the APs show as WPS disabled, something I doubt. 
Might be the driver for my oddball Alfa wifi adapter though.

Original comment by pascaldo...@gmail.com on 28 Mar 2013 at 8:35

I believe this problem is still due to a permission error not allowing fern 
complete access to the system resources.. Are you logged in using the root 
account.

Original comment by savioboy...@gmail.com on 28 Mar 2013 at 9:18

i haven't tested the program on kali yet, im still downloading it... but try 
running the program on terminal, run the update again and report the errors 
printed on terminal.

Original comment by savioboy...@gmail.com on 28 Mar 2013 at 10:06

@pascaldo...@gmail.com

Here is a fix for the WPS problem:

apt-get install libsqlite3-dev
mkdir /etc/reaver
wash -i mon0

-----------
Please guys i need feedbacks on the update error, so i can fix it..


Original comment by savioboy...@gmail.com on 28 Mar 2013 at 10:15

Yeah I'm in root alright. I will try the fix for WPS, wash -i turns out nothing 
for now. Will see after fix :), thanx guys.

Original comment by pascaldo...@gmail.com on 28 Mar 2013 at 6:31

Hey saviour, same issue here:

Fern won't run after updating from the program window in Kali 1.

After updating and running from the terminal I get the same error as pascaldo :
"/usr/bin/fern-wifi-cracker: line 3: /usr/share/fern-wifi-cracker/execute.py: 
Permission denied"

After chmod'ing the "execute.py" file fern will now run.

After fern updates and runs the update box will say: "Latest update is already 
installed" but if you click the update button it will still reinstall 1.9 
again, and this can be repeated unlimited time as long as the "execute.py" is 
chmod'ed after each (unnecessary) update.

Hope that gives you some more info!

Original comment by rahul_ch...@yahoo.com on 12 Apr 2013 at 8:35

Fix for WPS worked! Thanks guys!

Original comment by pascaldo...@gmail.com on 12 Apr 2013 at 8:40

[deleted comment]
Don't think I am a genius ... but glad that I could help.

The update worked and now I don't have to execute the .py file with chmod, but 
I am still able to update fern when it is already up to day, over and over 
again.

Not a big deal at all and thanks again for fixing it ... also is there any way 
for you to remove my complete e-mail address from your post above? :\

Original comment by rahul_ch...@yahoo.com on 13 Apr 2013 at 5:15

@rahul

ah.. ok, Thanks once again, Sorry for the email exposure.. :)

Original comment by saviob...@rocketmail.com on 13 Apr 2013 at 6:42

I tried the fix for the WPS issue with no luck. I have two instances running 
one on a Sony Vaio with an intle on wlan0 and one on a Dell mini using the b43 
drivers.  They both work on mon mode as well as injection and everything seems 
to work except on the dell mini it actually shows which AP's are using WPS and 
the same Aps on via the vaio show that they don’t support WPS.  I first 
noticed this issue when I installed my Atheros USB on the mini to enable a 
second Wlan the Atheros didn’t show the Ap's as being WPS compatible.  Both 
instances are updated running 1.9 and everything is up to date…using on Kali 
not Backtrack.


Original comment by erowin...@gmail.com on 22 May 2013 at 2:17

im still having a problem updating ..my update button is missing?? HELP!!

Original comment by wezel...@gmail.com on 21 Oct 2013 at 1:40

Which version of fern are you using.. Also please attach a screenahot .. Thank 
you for the report

Original comment by savioboy...@gmail.com on 21 Oct 2013 at 1:52

i believe im up to date but the button is missing.. TY for the fast reply

Original comment by wezel4...@gmail.com on 21 Oct 2013 at 2:05

Attachments:

[deleted comment]
When did the problem start. And i'ld like to ask if you made any change to the 
source...

Original comment by savioboy...@gmail.com on 21 Oct 2013 at 2:13

the problem has been since install of Kali yesterday.. no i haven't changed 
anything in source. also unrelated to Fern but may be able to help as well 
..cant connect to any wifi networks says wrong key but i know I'm using the 
right keys for my network.

Original comment by wezel...@gmail.com on 21 Oct 2013 at 2:19

OK.. Try reporting the problem on Kali or you could perhaps try reinstalling 
Kali

Original comment by savioboy...@gmail.com on 21 Oct 2013 at 2:23

TY for your help and FERN fukin rox ..LOVE IT 

Original comment by wezel...@gmail.com on 21 Oct 2013 at 2:49

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment