Permalink
Browse files

prepare for v1.0.0

  • Loading branch information...
1 parent 620f8d1 commit ba0b5b2f130c53cc27abaa4c04fb8aec9cf308af @rubiii rubiii committed Sep 28, 2011
Showing with 16 additions and 16 deletions.
  1. +0 −2 Gemfile
  2. +1 −1 lib/savon/spec/version.rb
  3. +15 −13 savon_spec.gemspec
View
@@ -1,4 +1,2 @@
source :rubygems
gemspec
-
-gem "autotest"
@@ -1,7 +1,7 @@
module Savon
module Spec
- VERSION = "0.1.6"
+ VERSION = "1.0.0"
end
end
View
@@ -1,25 +1,27 @@
-lib = File.expand_path("../lib/", __FILE__)
-$:.unshift lib unless $:.include?(lib)
-
+# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
require "savon/spec/version"
Gem::Specification.new do |s|
- s.name = "savon_spec"
- s.version = Savon::Spec::VERSION
- s.authors = "Daniel Harrington"
- s.email = "me@rubiii.com"
- s.homepage = "http://github.com/rubiii/#{s.name}"
- s.summary = "Savon testing library"
- s.description = "Test helpers for the Savon SOAP library."
+ s.name = "savon_spec"
+ s.version = Savon::Spec::VERSION
+ s.authors = "Daniel Harrington"
+ s.email = "me@rubiii.com"
+ s.homepage = "http://github.com/rubiii/#{s.name}"
+ s.summary = "Savon testing library"
+ s.description = s.summary
s.rubyforge_project = s.name
- s.add_dependency "savon", ">= 0.8.0"
+ s.add_dependency "savon", "~> 1.0"
@donaldpiret
donaldpiret Feb 21, 2012

Savon 1.0 is not in your repo anymore (did this change to 0.9.9? Was confused about this), so this is now broken

s.add_dependency "rspec", ">= 2.0.0"
- s.add_dependency "mocha", ">= 0.9.8"
s.add_development_dependency "httpclient", "~> 2.1.5"
- s.add_development_dependency "webmock", "~> 1.4.0"
+ s.add_development_dependency "webmock", "~> 1.4.0"
+ s.add_development_dependency "mocha", "~> 0.10.0"
+
+ s.add_development_dependency "autotest"
+ s.add_development_dependency "ZenTest", "4.5.0"
s.files = `git ls-files`.split("\n")
s.require_path = "lib"

0 comments on commit ba0b5b2

Please sign in to comment.