incompatible version warnings appear spurious #132

Closed
paulp opened this Issue Jul 27, 2011 · 2 comments

Projects

None yet

2 participants

@paulp
Contributor
paulp commented Jul 27, 2011

Maybe I'm easily confused, but aren't all these warnings spurious? I kept double-checking what version it was building against because I couldn't understand why it was hassling me about those versions.

// See, I set scalaHome, doesn't that mean all those versions are being ignored?
> inspect scala-instance     
[info] Setting: sbt.ScalaInstance = Scala instance{version label 2.9.1.r25384-b20110726180344, actual version 2.9.1.r25384-b20110726180344, library jar: /scala/inst/scala-2.9.1.RC2-SNAPSHOT/lib/scala-library.jar, compiler jar: /scala/inst/scala-2.9.1.RC2-SNAPSHOT/lib/scala-compiler.jar}

[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[info] Compiling 64 Scala sources and 8 Java sources to /soft/src/akka/akka-actor/target/classes...
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0-1, 2.8.1, 2.9.0, 2.8.0
[warn] Potentially incompatible versions specified:
[warn] Potentially incompatible versions specified:
[warn]    org.scala-lang: 2.9.0, 2.8.1
[warn]    org.scala-lang: 2.9.0, 2.8.1
[error] {file:/soft/src/akka/}akka-actor/compile: java.lang.reflect.InvocationTargetException
[error] Total time: 3 s, completed Jul 26, 2011 7:25:36 PM
@harrah
Member
harrah commented Jul 27, 2011

That is for dependency management. i.e., you have dependencies for both 2.9.0 and 2.8.1. The message has been improved to specify the project ID, but do you think something needs to indicate that it is due to dependency management or what?

@paulp
Contributor
paulp commented Jul 27, 2011

Well, some indication of why I'm supposed to care would be good. It says incompatible versions specified, but no hint of who is doing that, where it is happening, or what the relevance is to my life.

@harrah harrah closed this in d2ed74a Aug 23, 2011
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment