Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

155 lines (150 sloc) 5.99 kb
<?xml version="1.0" encoding="UTF-8"?>
<project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.scala-ide</groupId>
<artifactId>org.scala-ide.build-toolchain</artifactId>
<version>3.0.1-SNAPSHOT</version>
<relativePath>../org.scala-ide.build-toolchain/pom.xml</relativePath>
</parent>
<artifactId>org.scala-ide.sbt.full.library</artifactId>
<packaging>bundle</packaging>
<!-- extra repository containing the sbt packages -->
<repositories>
<repository>
<id>typesafe-ide</id>
<name>Typesafe IDE repository</name>
<url>${repo.typesafe}</url>
</repository>
</repositories>
<dependencies>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>classpath_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>logging_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>io_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>control_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>classfile_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>process_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>relation_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>interface_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>persist_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>api_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>compiler-integration_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>incremental-compiler_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>compile_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-sbt</groupId>
<artifactId>compiler-interface_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
<!-- all the dependencies necessary for running like sbinary, jline -->
<dependency>
<groupId>jline</groupId>
<artifactId>jline</artifactId>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.scala-tools.sbinary</groupId>
<artifactId>sbinary_${sbt.compiled.version}</artifactId>
<optional>true</optional>
</dependency>
</dependencies>
<build>
<outputDirectory>${basedir}</outputDirectory>
<plugins>
<plugin>
<!-- automatically clean up the generated META-INF folder -->
<artifactId>maven-clean-plugin</artifactId>
<configuration>
<excludeDefaultDirectories>true</excludeDefaultDirectories>
<filesets>
<fileset>
<directory>./</directory>
<includes>
<include>lib/**/*</include>
<include>lib</include>
<include>META-INF/**/*</include>
<include>META-INF</include>
<include>target/**/*</include>
<include>target</include>
</includes>
<followSymlinks>false</followSymlinks>
</fileset>
</filesets>
</configuration>
</plugin>
<plugin>
<!-- generate the MANIFEST.MF file, and create the bundle -->
<groupId>org.apache.felix</groupId>
<artifactId>maven-bundle-plugin</artifactId>
<configuration>
<manifestLocation>${basedir}/META-INF</manifestLocation>
<instructions>
<Bundle-SymbolicName>org.scala-ide.sbt.full.library</Bundle-SymbolicName>
<Bundle-Name>Sbt ${sbt.version} Library for Eclipse</Bundle-Name>
<!-- put a '-' after the sbt.version since it already has a '-scalaide-01' qualifier. Remove it the qualifier is gone. -->
<Bundle-Version>${sbt.version}-${version.suffix}-${maven.build.timestamp}</Bundle-Version>
<Embed-Dependency>*;scope=compile|runtime;inline=false</Embed-Dependency>
<_exportcontents>sbt.*;version=${sbt.version},xsbt.*;version=${sbt.version},xsbti.*;version=${sbt.version},sbinary.*;version=${sbinary.version},jline.*;version=2.10,org.apache.ivy.*;version=2.2.0</_exportcontents>
<Embed-Directory>lib</Embed-Directory>
<Embed-StripVersion>true</Embed-StripVersion>
<Import-Package>!org.apache.ivy.*,!org.bouncycastle.*,!org.scalatools.testing.*,!com.craft.*,!com.jcraft.*,!sun.misc,!org.apache.commons.vfs,!org.apache.commons.vfs.impl,!org.apache.oro.text,!org.apache.oro.text
.regex,*</Import-Package>
</instructions>
</configuration>
</plugin>
</plugins>
</build>
</project>
Jump to Line
Something went wrong with that request. Please try again.