Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge pull request #539 from dotta/wip/fix-osgi-version-number-in-sbt…

…-bundles

Use the ${sbt.osgi.version} when exporting packages of the sbt bundles
  • Loading branch information...
commit 6e125b6cc6830dba665e38b701b20ceef9ce9a9d 2 parents 515c7f1 + 4d10967
@dotta dotta authored
View
2  org.scala-ide.sbt.compiler.interface/pom.xml
@@ -48,7 +48,7 @@
<Bundle-Name>Sbt Compiler Interface for Eclipse</Bundle-Name>
<Bundle-Version>${sbt.osgi.version}</Bundle-Version>
<Embed-Dependency>*;scope=compile|runtime;inline=true</Embed-Dependency>
- <_exportcontents>xsbt.*;version=${sbt.version}</_exportcontents>
+ <_exportcontents>xsbt.*;version=${sbt.osgi.version}</_exportcontents>
<Embed-StripVersion>true</Embed-StripVersion>
</instructions>
</configuration>
View
2  org.scala-ide.sbt.full.library/pom.xml
@@ -143,7 +143,7 @@
<Bundle-Name>Sbt Library for Eclipse</Bundle-Name>
<Bundle-Version>${sbt.osgi.version}</Bundle-Version>
<Embed-Dependency>*;scope=compile|runtime;inline=true</Embed-Dependency>
- <_exportcontents>sbt.*;version=${sbt.version},xsbt.*;version=${sbt.version},xsbti.*;version=${sbt.version},sbinary.*;version=${sbt.version}</_exportcontents>
+ <_exportcontents>sbt.*;version=${sbt.osgi.version},xsbt.*;version=${sbt.osgi.version},xsbti.*;version=${sbt.osgi.version},sbinary.*;version=${sbt.osgi.version}</_exportcontents>
<Embed-StripVersion>true</Embed-StripVersion>
</instructions>
</configuration>
Please sign in to comment.
Something went wrong with that request. Please try again.