Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Commits on Jul 10, 2012
  1. @dragos

    Bumped sbt version.

    dragos authored
Commits on Jul 4, 2012
  1. @dragos

    Depend on a minimal set of Sbt artifacts.

    dragos authored
    Fixes the build for 2.10.
Commits on Jun 8, 2012
  1. @dragos
  2. @skyluc

    Adds generation of the toolchain update site

    skyluc authored
    In a new maven project/folder
Commits on Jun 7, 2012
  1. @skyluc

    Added extra compiler jar

    skyluc authored
    Correctly configure optional dependencies
  2. @skyluc

    Clean up and simplification of the poms

    skyluc authored
    Made the dependencies of library, compiler and sbt optional, so they don't have to be excluded later.
    Moved the 'allowConflictingDependencies' option to the projects which require it (feature and site).
    It is needed because of the mix of versions for the elements coming from the m2 repo.
    Removed the dependency to aspectjrt (not needed)
    Cleaned-up an invalid property definition in sbt.full.library.
    Created properties for all plugin version numbers
    Fixed typo
    Fixed git location
    Added parameter to the p2 repositories ids
Commits on Jun 5, 2012
  1. @skyluc

    Major refactoring of the maven build.

    skyluc authored
    No bash script needed anymore. Everything is managed through maven.
    The new pom at in root folder contains version information and general configuration.
    org.scala-ide.build-toolchain is the root of the toolchain part
    org.scala-ide.sbt.build is the root of the sdt part
    The version numbers of some plugins has been upgraded
    
    The downloaded libs have been moved to the target/lib folders, to simplify the clean up process.
    
    The first time, run './build-all.sh (or './build-all.sh install -P scala-2.10.x' for 2.10) from the root to generate an initial build and install the top pom locally. Then use maven from any project or subproject.
    
    Use the scala-2.10.x profile ('-P scala-2.10.x') to compile the 2.10 version.
    
    Re #1001056
Something went wrong with that request. Please try again.